<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta name="theme-color" content="#F0F0F0">
<meta name="msapplication-TileColor" content=#F0F0F0>
<meta property="og:locale" content="en_GB">
<meta property="og:locale:alternate" content="en_US">
<meta property="og:type" content="website" />
<meta name="robots" content="index,follow">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="copyright" content="Nation Media Group">
<script src="/cdn-cgi/apps/head/FeR9CVqV-P9wYFXh56D_UdBIx0I.js"></script><link rel="manifest" href="https://nairobinews.nation.co.ke/manifest.json">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" />
<link rel="amphtml" href="https://nairobinews.nation.co.ke/amp/news/nms-employees-go-without-salaries-as-sonko-badi-fight">
<link rel="shortcut icon" type="image/x-icon" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon.ico">
<link rel="icon" type="image/png" sizes="32x32" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-64x64.png">
<link rel="icon" type="image/png" sizes="24x24" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-24x24.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-16x16.png">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/css/main_v3.css?v=1">
<title>NMS employees go without salaries as Sonko, Badi fight &#8211; Nairobi News</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.co.ke/feed" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.co.ke/comments/feed" />
<meta property="og:title" content="NMS employees go without salaries as Sonko, Badi fight" />
<meta property="og:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" />
<meta property="og:site_name" content="Nairobi News" />
<meta property="og:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi.jpg" />
<meta name="keywords" content="Deed of Transfer,Mike Sonko,Mohammed Badi,NMS,Ukur Yatani," />
<meta property="fb:app_id" content="119242211439858" />
<meta property="fb:pages" content="497615353664351" />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2020-10-22 22:30:22" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Nairobi_News" />
<meta name="twitter:title" content="NMS employees go without salaries as Sonko, Badi fight" />
<meta name="twitter:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta name="twitter:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi.jpg" />
<meta name="twitter:url" content="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nairobinews.nation.co.ke\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='_nn_clean-style-css' href='https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/style.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://nairobinews.nation.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.10" />
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" />
<link rel='shortlink' href='https://nairobinews.nation.co.ke/?p=174489' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Fnms-employees-go-without-salaries-as-sonko-badi-fight" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Fnms-employees-go-without-salaries-as-sonko-badi-fight&#038;format=xml" />


<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script src="https://cdn.nation.co.ke/dmp/bluekai-dfp-header-integration.js" type="text/javascript"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-4');
    </script>


<script type="text/javascript">
        _atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.co.ke",dynamic: true};
        (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
    </script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
		  googletag.cmd.push(function() {

window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }

			googletag.defineOutOfPageSlot('/1010816/NN-Profit-Button', 'div-gpt-ad-1560489456971-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });
		</script>

<div id='div-gpt-ad-1560489456971-0'>
<script>
        googletag.cmd.push(function() {
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }        
         googletag.display('div-gpt-ad-1560489456971-0'); });
        </script>
</div>
<script type="text/javascript">
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
                document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
                'tb_loader_script');
        </script>
<script type="text/javascript">
        var _sf_async_config = _sf_async_config || {};
        /** CONFIGURATION START **/
        _sf_async_config.uid = 63208; // ACCOUNT NUMBER
        _sf_async_config.domain = 'nairobinews.nation.co.ke'; // DOMAIN
        _sf_async_config.flickerControl = false;
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = false;
        /** CONFIGURATION END **/
        var _sf_startpt = (new Date()).getTime();
    </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />
</head>
<body class="inner-body">
<div id="content_overlay"></div>
<div id="mp-menu" class="mp-menu">
<div class="mp-level">
<div class="mp-level-scroll">
<div class="search-form">
<div class="form-container posRelative">

<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
<ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> <div class="whats-appLink">
<div class="title">Join our Telegram Channel</div>
<a href="https://telegram.me/NairobiNews">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp</span>
</a>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<span class="title">Connect with us</span>
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>

</ul>
</div>
</div>
</div>
</div>
</div>
<div id="top-section">
<header id="main-header" class="clearfix">
 <div class="row">
<div class="row">
<div class="grid-2 cell">
<div class="site-branding">
<h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
<div class="site-logo mobile-hidden">
<a href="https://nairobinews.nation.co.ke/?"><img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
</div>
</div>
</div>
<div class="grid-10 cell">
<div class="ad-container nobg">
<div id="custom_html-26" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div> </div>
</div>
</div>
</div>
<div id="mobile-menu" class="mobile-menu web-hidden">
<div class="row">
<div class="row">
<div class="grid-6 cell">
<div class="site-logo">
<a href="https://nairobinews.nation.co.ke">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-black.svg" alt="Nairobi News Logo" />
</a>
</div>
</div>
<div class="grid-6 cell">
<div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
<div class="line-menu"></div>
<div class="line-menu"></div>
<div class="line-menu"></div>
</div>
</div>
</div>
</div>
</div>
</header>
<nav id="main-navigation" class="main-nav clearfix" role="nav">
<div class="content">
<div class="row">
<div class="nav-left">
<ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> </div>
<div class="nav-right">
<div id="search-show" class="right-search">
<div class="right-search__icon search-close">
<span class="fa fa-search"></span>
</div>
<div class="search-form">
<div class="form-container">
<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>
<li id="alerts" class="alert close">
<a href="javascript:void(0);" title="Updates made in the last 20 minutes">
<span class="alert-num">
0 </span>
<i class="fa fa-bell"></i>
<span class="hide">Alerts</span>
</a>
</li>
</ul>
</div>
</div>
<div id="dropdown-latest" class="dropdown-item">
<div class="dropdown-content">

</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<main id="main-content" role="content">
<main id="main-content" role="content" class='main_content'>
<section id="single-content" class="single-content mt-40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-8 cell">
<div class="single-container">
<div class="article-content">
<div class="article-content__top">
<div class="content-top__title">
<span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/news">News</a></span> <h2>NMS employees go without salaries as Sonko, Badi fight</h2>
</div>
<div class="content-top__meta mt-20 clearfix">
<div class="row">
<div class="grid-6 cell">
<div class="meta-articles__details">
<div class="meta-avatar">
<div class="avatar-content">
<div class="avatar-content__img wp-post-image" data-bg="url()"></div>
</div>
</div>
<div class="meta-details">
<div class="meta-author">
<span class="render-text by">
<span class="mr-5">By</span>
<a href="javascript:void(0);" role="author">
Collins Omulo </a></span>
<span>October 22nd, 2020 <i class="dot"></i> 2 min read</span>
</div>
</div>
</div>
</div>
<div class="grid-6 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li>
<span>Share this</span>
</li>
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;t=NMS employees go without salaries as Sonko, Badi fight" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;t=NMS employees go without salaries as Sonko, Badi fight" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;text=NMS employees go without salaries as Sonko, Badi fight&via=Nairobi_News" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&title=NMS employees go without salaries as Sonko, Badi fight&summary=NMS employees go without salaries as Sonko, Badi fight&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#e6d99593848c838592dba8abb5c6838b968a899f838395c68189c6918f928e899392c695878a87948f8395c68795c6b589888d89cac6a487828fc6808f818e92c08489829fdb8e92929695dcc9c988878f9489848f88839195c88887928f8988c88589c88d83c988839195c9888b95cb838b968a899f838395cb8189cb918f928e899392cb95878a87948f8395cb8795cb9589888d89cb8487828fcb808f818e92" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
<li class="email" style="display: none;">
<a href="javascript:void(0);" id="#work" title="Share this via PWA" style="display: none;">
<i class="fa fa-share-alt"></i>
<span class="hide">Share this via PWA</span>
</a>
</li>
</ul>
</div>
 </div>
</div>
</div>
</div>
</div>
<div class="article-content__banner">
<div class="banner-container">
<div class="banner-image">
<img width="1320" height="879" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi-150x150.jpg" class="attachment-single-image size-single-image wp-post-image" alt="Mohammed Badi" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi-470x264.jpg" title="Mohammed Badi" /> </div>
<div class="banner-caption">

<span class="render-text">Director General of Nairobi Metropolitan Services Major General Mohamed Abdalla Badi address journalist during a presser on Corona crisis at Afya House on March 20 2020.PHOTO|SILA KIPLAGAT</span> </div>
</div>
</div>
<div class="article-content__content clearfix mt-40">
<div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
											googletag.cmd.push(function() {
											googletag.defineSlot('/1010816/NN-ARTICLE-4', [300, 250], 'div-gpt-ad-1553666013837-0').addService(googletag.pubads());
											googletag.enableServices(); });
											</script>
<div id='div-gpt-ad-1553666013837-0' style='height:250px; width:300px;'>
<script>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553666013837-0'); });
											</script>
</div>
<br />
</div>
<p>More than 6,800 employees of Nairobi County seconded to Nairobi Metropolitan Services (NMS) will wait longer for their salaries after the National Treasury declined to release money for payment of salaries.</p>
<p>This is after National Treasury Cabinet Secretary Ukur Yatani declined a request by the Major General Mohammed Badi-led office to release the funds until a dispute between the agency and Governor Mike Sonko is resolved.</p><div class="other-stories related-content clearfix"><div class="grid-12 cell"><h3>Related Stories</h3></div><div class="row"><ul><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/general/sonko-claims-the-system-served-him-alcohol-at-state-house><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/02/Mike-SOnko-150x150.jpg" /></span><span class="related-content__text">Sonko claims the &#8216;system&#8217; served him alcohol at State House</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/featured/sonko-state-house-served-me-alcohol-before-i-surrendered-nairobi-to-uhuru><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/02/Mike-SOnko-150x150.jpg" /></span><span class="related-content__text">Sonko: State House served me alcohol before I surrendered Nairobi to Uhuru</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/news/mcas-threaten-sonko-with-fresh-impeachment-motion-over-war-with-nms><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/09/DnEACCSonko0309du-150x150.jpg" /></span><span class="related-content__text">MCAs threaten Sonko with fresh impeachment motion over war with NMS</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/news/senior-city-hall-officers-say-they-have-been-neglected-by-badis-nms><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/03/ETZTcfLXkAExEPl-150x150.jpg" /></span><span class="related-content__text">Senior City Hall officers say they have been neglected by Badi&#8217;s NMS</span></a></li></div></ul></div></div>
<p>In a letter addressed to NMS Director General Badi, Yatani said there was no legal framework in place to facilitate such a transaction and that the funds can only be remitted to the Nairobi County Government (NCCG) Revenue Fund Account and not to NMS.</p>
<p>He pointed out that Section 4(2) of County Allocation of Revenue Act (CARA), 2020 provides that each county governments’ allocation shall be transferred to the respective County Revenue Fund, in accordance with a payment schedule approved by the senate and published in the Kenya gazette by the CS, in accordance with section 17of PFM Act, 2012.</p>
<p>&#8220;The above legal provisions therefore imply that equitable share allocation due to Nairobi City County Government, including monies for personnel emoluments, shall be transferred to NCCG Revenue Fund Account,&#8221; Mr Yatani said in a letter dated October 15, 2020.</p>
<p>Mr Yatani explained that specific tenets of the law made it illegal to approve such a transaction since there is an unresolved dispute between City Hall and NMS on matters budgeting, oversight of NMS funds and secondment of staff to NMS.</p>
<p>The current stalemate stems from a notice of a declaration of dispute registered by Governor Sonko on July 24, 2020.</p>
<p>Talks over the dispute between the two entities is now with the office of the Attorney General where Solicitor Kennedy Ogeto is spearheading the arbitration committee with a view to coming up with an agreeable solution.</p><div class='mobile-ad' style='padding:5px;'>

<div id='div-gpt-ad-1547187122892-0'>
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547187122892-0'); });
				</script>
</div>
</div>
<h2>Deed of Transfer</h2>
<p>Mr Yatani said parties to the Deed of Transfer of functions from City Hall to the National Government entered into an interim settlement agreement as an expression of good faith and commitment to an amicable resolution of the matters in dispute.</p>
<p>Consequently, pursuant to Article 112 of the Deed of Transfer that provides that parties shall, in the first instance, endeavor to resolve disputes governed by, or arising from the Deed of Transfer amicably through negotiations, the National Treasury is waiting for the resolution to the disputes before taking any action.</p>
<p>&#8220;Given the above legal provisions and the ongoing negotiations, the National Treasury awaits further guidance from the office of the attorney general on the way forward on the above issues,” said Mr Yatani.</p>
<p>The CS was responding to a letter by Maj Gen Badi dated September 3, 2020 in which the NMS boss requested the National Treasury to release funds to pay salaries of the 6,852 county staff.</p>
<p>This is after health workers under the NMS took to the streets protesting over, among other things, the delayed salaries.</p>
<p>Their woes have further been compounded by the dispute between NMS and City Hall over employees&#8217; payroll.</p>
<p>NMS wants City Hall to handover the staff payroll to enable it pay staff seconded to it.</p>
<p>City Hall, on the other hand, maintains that it is the sole custodian of the staff payroll, since the role of payment of salaries still lies with the Nairobi County Government.</p>
 </div>
<div class="article-content__tags">
<div class="list-tags">
<ul class="unstyled"><li><a href="https://nairobinews.nation.co.ke/tag/deed-of-transfer" rel="tag">Deed of Transfer</a></li><li><a href="https://nairobinews.nation.co.ke/tag/mike-sonko" rel="tag">Mike Sonko</a></li><li><a href="https://nairobinews.nation.co.ke/tag/mohammed-badi" rel="tag">Mohammed Badi</a></li><li><a href="https://nairobinews.nation.co.ke/tag/nms" rel="tag">NMS</a></li><li><a href="https://nairobinews.nation.co.ke/tag/ukur-yatani" rel="tag">Ukur Yatani</a></li></ul>
</div>
<div class="join-wc clearfix">
<div class="row">
<div class="grid-8 cell">
<div class="join-text">
<p>Nairobi News is now available on Telegram. For handpicked stories every day, subscribe to our channel today</p>
</div>
</div>
<div class="grid-4 cell">
<div class="join-link whats-appLink">
<a href="https://telegram.me/NairobiNews" target="_blank">
<i class="fa fa-commenting-o"></i>
<span>Telegram channel</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="stick-article-nav" class="article-content___nav">
<div class="row">
<div class="grid-4 cell">
<div class="content-nav__item prev-item">
<a href="https://nairobinews.nation.co.ke/news/uhuru-seeks-first-ladys-permission-to-get-someone-from-kisumu-videos" title="Uhuru seeks First Lady’s permission to get “someone” from Kisumu &#8211; VIDEOS">
<span class="hide-mobile">
Uhuru seeks First Lady’s permission to get “someone”... </span>
</a>
</div>
</div>
<div class="grid-4 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;t=NMS employees go without salaries as Sonko, Badi fight" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;t=NMS employees go without salaries as Sonko, Badi fight" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&amp;text=NMS employees go without salaries as Sonko, Badi fight&via=Nairobi_News" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight&title=NMS employees go without salaries as Sonko, Badi fight&summary=NMS employees go without salaries as Sonko, Badi fight&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#033c707661696660773e4d4e5023666e736f6c7a66667023646c23746a776b6c76772370626f62716a667023627023506c6d686c2f234162676a23656a646b7725616c677a3e6b77777370392c2c6d626a716c616a6d6674702d6d62776a6c6d2d606c2d68662c6d6674702c6d6e702e666e736f6c7a6666702e646c2e746a776b6c76772e70626f62716a66702e62702e706c6d686c2e6162676a2e656a646b77" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="grid-4 cell">
</div>
</div>
</div>
</div>
<div class="articles-content__author mt-40">

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight";
                                        _sf_async_config.title = "NMS employees go without salaries as Sonko, Badi fight";
                                        _sf_async_config.sections = "News,";
                                        _sf_async_config.authors = "Collins Omulo ";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>


<script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "174489",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "NMS employees go without salaries as Sonko, Badi fight",
                                            pubdate: "2020-10-22",
											authors: "Collins Omulo ",								
											sections: "News,",
                                            tags: "Deed of Transfer, Mike Sonko, Mohammed Badi, NMS, Ukur Yatani, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>

<br />
<div id="custom_html-22" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-0846142691248784" data-ad-slot="4659675794" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> </div>
</div>
</div>
<div class="grid-4 cell">
<div class="ad-container">
<div id="custom_html-6" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-2', [300, 250], 'div-gpt-ad-1553665892910-0').addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665892910-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665892910-0'); });
</script>
</div></div></div>
</div>
<div id="mustr-pane" class="vidoes-pane mt-20">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://nairobinews.nation.co.ke/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/uhuru-seeks-first-ladys-permission-to-get-someone-from-kisumu-videos">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Uhuru-Kisumu-2-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Uhuru seeks First Lady’s permission to get “someone”...</h3>
 </div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/babu-owino-takes-flak-for-unsolicited-advice-to-kenyans-on-bbi-report">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Babu-Owino-II-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Babu Owino takes flak for unsolicited advice to Kenyans on...</h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/nairobi-to-lose-four-key-functions-if-bbi-report-is-adopted">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi-mike-sonko-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Nairobi to lose four key functions if BBI report is adopted</h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/kbc-news-anchor-tests-positive-for-coronavirus">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Purity-Museo-1-copy-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
 <h3>KBC news anchor tests positive for Coronavirus</h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/chillax/why-male-relatives-are-banned-from-jua-calis-house">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/08/BuzzTwendeKazi1i-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Why male relatives are banned from Jua Cali’s house</h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/ex-ps-lilian-omollo-awarded-only-sh1-for-unfair-dismissal">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/02/DNCourtsNairobi2801th-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Ex-PS Lilian Omollo awarded only Sh1 for unfair dismissal</h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="ad-container">
<div id="custom_html-7" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-3', [300, 250], 'div-gpt-ad-1553665956712-0').addService(googletag.pubads());
googletag.enableServices(); });
</script>
<div id='div-gpt-ad-1553665956712-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665956712-0'); });
</script>
</div></div></div>  </div>
<div id="buzz-pane" class="buzz-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
</div>
</div>
<div id="taboola-ads" class="taboola-ad-below-article content-sticky">

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>

</div>
</div>
</div>
</div>
</div>
<div class="smart_scroll_container" id='post-174478'></div>
</section>
</main>
<footer id="main-footer" class="mt-40" role="footer">
<div class="top-footer padt40 padb40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-4 cell">
<div class="top-footer__about">
<div class="about-logo__img">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-footer.png" alt="Nairobi News Logo" />
</div>
<div id="custom_html-20" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">Nairobi News is the most trusted website in Kenya that provides the latest breaking news, entertainment news, sports news, showbiz and celebrity stories.
will also keep you hooked with memes, gifs and funny videos.</div></span></div><div id="custom_html-21" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">
<div id='div-gpt-ad-1540468650627-0'>
<script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540468650627-0'); });
        </script>
</div> </div></span></div>

</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Most Popular</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/featured/zuchu-denies-revolt-in-wasafi-over-her-fast-rising-star"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Zuchu-copy-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Zuchu- copy" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Zuchu-copy-470x264.jpg" title="Zuchu- copy" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/featured/zuchu-denies-revolt-in-wasafi-over-her-fast-rising-star">Zuchu denies revolt in Wasafi over her fast-rising star</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 16th, 2020</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/anne-kiguta-faces-off-with-mediamax-over-cancelled-ndindi-nyoro-interview-video"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Kiguta-Punchline-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Kiguta Punchline" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Kiguta-Punchline-470x264.jpg" title="Kiguta Punchline" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/anne-kiguta-faces-off-with-mediamax-over-cancelled-ndindi-nyoro-interview-video">Anne Kiguta faces off with Mediamax over cancelled Ndindi Nyoro interview &#8211; VIDEO</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 19th, 2020</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/editors-picks/developers-move-to-rescue-africas-tallest-building-dream"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/02/BDLPinnacle1-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="BDLPinnacle1" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/02/BDLPinnacle1-470x264.jpg" title="BDLPinnacle1" /></a>
 </div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/editors-picks/developers-move-to-rescue-africas-tallest-building-dream">Developers move to rescue ‘Africa’s tallest building’ dream</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 16th, 2020</span>
</div>
</div>
</div>
</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Don't Miss</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Mohammed Badi" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Mohammed-Badi-470x264.jpg" title="Mohammed Badi" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/nms-employees-go-without-salaries-as-sonko-badi-fight">NMS employees go without salaries as Sonko, Badi fight</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/uhuru-seeks-first-ladys-permission-to-get-someone-from-kisumu-videos"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Uhuru-Kisumu-2-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Uhuru Kisumu 2" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Uhuru-Kisumu-2-470x264.jpg" title="Uhuru Kisumu 2" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/uhuru-seeks-first-ladys-permission-to-get-someone-from-kisumu-videos">Uhuru seeks First Lady’s permission to get “someone” from Kisumu &#8211; VIDEOS</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/editors-picks/babu-owino-takes-flak-for-unsolicited-advice-to-kenyans-on-bbi-report"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Babu-Owino-II-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Babu-Owino-II" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Babu-Owino-II-470x264.jpg" title="Babu-Owino-II" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/editors-picks/babu-owino-takes-flak-for-unsolicited-advice-to-kenyans-on-bbi-report">Babu Owino takes flak for unsolicited advice to Kenyans on BBI report</a></h3>
</div>
<div class="content-meta">
<span class="render-text">October 22nd, 2020</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-footer text-center padt20 padb20">
<span class="render-text">
Copyright &copy; 2020 Nation Media Group. All rights reserved.
</span>
</div>
</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/plugins.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript">
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#!'+id;
          window.history.pushState({path:newurl},'',newurl);
		  //alert(id);
      }
    }
</script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-includes/js/wp-embed.min.js'></script>



<iframe name="__bkframe" height="0" width="0" frameborder="0" style="display:none;position:absolute;clip:rect(0px 0px 0px 0px)" src="about:blank"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript">
bk_allow_multiple_calls=true;
bk_meta_vars=[];
bk_doJSTag(80213, 1);
</script>

<script src="https://d35ul1o6ah7bnm.cloudfront.net/africa/sdk/justslide.min.js" async="async"></script>
<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-1030601-4', 'auto');
	ga(function(tracker) {
	  justslide.configure(42, 'UA-1030601-4', tracker.get('clientId'));
	  justslide.pageview();
	});
</script>

</body>
</html>