<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta name="theme-color" content="#F0F0F0">
<meta name="msapplication-TileColor" content=#F0F0F0>
<meta property="og:locale" content="en_GB">
<meta property="og:locale:alternate" content="en_US">
<meta property="og:type" content="website" />
<meta name="robots" content="index,follow">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="copyright" content="Nation Media Group">
<script src="/cdn-cgi/apps/head/VVVOWwpa_ruLWtjwa-hDVvK98kc.js"></script><link rel="manifest" href="https://nairobinews.nation.co.ke/manifest.json">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" />
<link rel="amphtml" href="https://nairobinews.nation.co.ke/amp/hashtag/matiangi-we-even-guard-rutos-chicken">
<link rel="shortcut icon" type="image/x-icon" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon.ico">
<link rel="icon" type="image/png" sizes="32x32" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-64x64.png">
<link rel="icon" type="image/png" sizes="24x24" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-24x24.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-16x16.png">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/css/main_v3.css?v=1">
<title>Matiang&#8217;i: We even guard Ruto&#8217;s chicken &#8211; Nairobi News</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.co.ke/feed" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.co.ke/comments/feed" />
<meta property="og:title" content="Matiang&#8217;i: We even guard Ruto&#8217;s chicken" />
<meta property="og:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" />
<meta property="og:site_name" content="Nairobi News" />
<meta property="og:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2019/08/Fred-Matiangi.jpg" />
<meta name="keywords" content="Fred Mataiang'i,William Ruto," />
<meta property="fb:app_id" content="119242211439858" />
<meta property="fb:pages" content="497615353664351" />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2021-09-01 14:51:32" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Nairobi_News" />
<meta name="twitter:title" content="Matiang&#8217;i: We even guard Ruto&#8217;s chicken" />
<meta name="twitter:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta name="twitter:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2019/08/Fred-Matiangi.jpg" />
<meta name="twitter:url" content="https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nairobinews.nation.co.ke\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='_nn_clean-style-css' href='https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/style.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://nairobinews.nation.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.10" />
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" />
<link rel='shortlink' href='https://nairobinews.nation.co.ke/?p=179991' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Fmatiangi-we-even-guard-rutos-chicken" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Fmatiangi-we-even-guard-rutos-chicken&#038;format=xml" />


<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script src="https://cdn.nation.co.ke/dmp/bluekai-dfp-header-integration.js" type="text/javascript"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-4');
    </script>


<script type="text/javascript">
        _atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.co.ke",dynamic: true};
        (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
    </script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
		  googletag.cmd.push(function() {

window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }

			googletag.defineOutOfPageSlot('/1010816/NN-Profit-Button', 'div-gpt-ad-1560489456971-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });
		</script>

<div id='div-gpt-ad-1560489456971-0'>
<script>
        googletag.cmd.push(function() {
window.bk_dfp_integration = window.bk_dfp_integration || {}; window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {}; if(typeof bk_dfp_integration.functions.sendDfp === "function"){ bk_dfp_integration.functions.sendDfp(); }        
         googletag.display('div-gpt-ad-1560489456971-0'); });
        </script>
</div>
<script type="text/javascript">
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
                document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
                'tb_loader_script');
        </script>

<script>
      var esadt = esadt || {};esadt.cmd = esadt.cmd || [];(function () {var s = document.createElement('script');s.async = true;s.type = 'text/javascript';var useSSL = 'https:' == document.location.protocol;s.src = (useSSL ? 'https:' : 'http:') + '//sspjs.eskimi.com/esadt.js';var n = document.getElementsByTagName('script')[0];n.parentNode.insertBefore(s, n)})();
    </script>
<script type="text/javascript">
        var _sf_async_config = _sf_async_config || {};
        /** CONFIGURATION START **/
        _sf_async_config.uid = 63208; // ACCOUNT NUMBER
        _sf_async_config.domain = 'nairobinews.nation.co.ke'; // DOMAIN
        _sf_async_config.flickerControl = false;
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = false;
        /** CONFIGURATION END **/
        var _sf_startpt = (new Date()).getTime();
    </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PH7GQKX');</script>

<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="inner-body">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PH7GQKX" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="content_overlay"></div>
<div id="mp-menu" class="mp-menu">
<div class="mp-level">
<div class="mp-level-scroll">
<div class="search-form">
<div class="form-container posRelative">

<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
<ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> <div class="whats-appLink">
<div class="title">Join our Telegram Channel</div>
<a href="https://telegram.me/NairobiNews">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp</span>
</a>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<span class="title">Connect with us</span>
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>

</ul>
</div>
</div>
</div>
</div>
</div>
<div id="top-section">
<header id="main-header" class="clearfix">
<div class="row">
<div class="row">
<div class="grid-2 cell">
<div class="site-branding">
<h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
<div class="site-logo mobile-hidden">
<a href="https://nairobinews.nation.co.ke/?"><img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
</div>
</div>
</div>
<div class="grid-10 cell">
<div class="ad-container nobg">
<div id="custom_html-26" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div> </div>
</div>
</div>
</div>
<div id="mobile-menu" class="mobile-menu web-hidden">
<div class="row">
<div class="row">
<div class="grid-6 cell">
<div class="site-logo">
<a href="https://nairobinews.nation.co.ke">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-black.svg" alt="Nairobi News Logo" />
</a>
</div>
</div>
<div class="grid-6 cell">
<div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
<div class="line-menu"></div>
<div class="line-menu"></div>
<div class="line-menu"></div>
</div>
</div>
</div>
</div>
</div>
</header>
<nav id="main-navigation" class="main-nav clearfix" role="nav">
<div class="content">
<div class="row">
<div class="nav-left">
<ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> </div>
<div class="nav-right">
<div id="search-show" class="right-search">
<div class="right-search__icon search-close">
<span class="fa fa-search"></span>
</div>
<div class="search-form">
<div class="form-container">
<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>
<li id="alerts" class="alert close">
<a href="javascript:void(0);" title="Updates made in the last 20 minutes">
<span class="alert-num">
0 </span>
<i class="fa fa-bell"></i>
<span class="hide">Alerts</span>
</a>
</li>
</ul>
</div>
</div>
<div id="dropdown-latest" class="dropdown-item">
<div class="dropdown-content">

</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<main id="main-content" role="content">
<main id="main-content" role="content" class='main_content'>
<section id="single-content" class="single-content mt-40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-8 cell">
<div class="single-container">
<div class="article-content">
<div class="article-content__top">
<div class="content-top__title">
<span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/hashtag">Hashtag</a></span><span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/news">News</a></span><span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/featured">What's Hot</a></span> <h2>Matiang&#8217;i: We even guard Ruto&#8217;s chicken</h2>
</div>
<div class="content-top__meta mt-20 clearfix">
<div class="row">
<div class="grid-6 cell">
<div class="meta-articles__details">
<div class="meta-avatar">
<div class="avatar-content">
<div class="avatar-content__img wp-post-image" data-bg="url()"></div>
</div>
</div>
<div class="meta-details">
<div class="meta-author">
<span class="render-text by">
<span class="mr-5">By</span>
<a href="javascript:void(0);" role="author">
Hillary Kimuyu</a></span>
<span>September 1st, 2021 <i class="dot"></i> 1 min read</span>
</div>
</div>
</div>
</div>
<div class="grid-6 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li>
<span>Share this</span>
</li>
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;t=Matiang&#8217;i: We even guard Ruto&#8217;s chicken" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;t=Matiang&#8217;i: We even guard Ruto&#8217;s chicken" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;text=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&via=Nairobi_News" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&title=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&summary=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#536c202631393630276e1e32273a323d3475706b616264683a69730436733625363d733426322137730126273c75706b616264682073303b3a3038363d75313c372a6e3b27272320697c7c3d323a213c313a3d3624207d3d32273a3c3d7d303c7d38367c3d3624207c3e32273a323d343a7e24367e3625363d7e34263221377e2126273c207e303b3a3038363d" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
 <span class="hide">WhatsApp</span>
</a>
</li>
<li class="email" style="display: none;">
<a href="javascript:void(0);" id="#work" title="Share this via PWA" style="display: none;">
<i class="fa fa-share-alt"></i>
<span class="hide">Share this via PWA</span>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="article-content__banner">
<div class="banner-container">
<div class="banner-image">
<img width="1320" height="742" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/08/Fred-Matiangi-150x150.jpg" class="attachment-single-image size-single-image wp-post-image" alt="Fred-Matiangi" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/08/Fred-Matiangi-470x264.jpg" title="Fred-Matiangi" /> </div>
<div class="banner-caption">

<span class="render-text">Interior and Co-ordination of National Government Cabinet Secretary Fred Matiang'i. PHOTO | FILE</span> </div>
</div>
</div>
<div class="article-content__content clearfix mt-40">
<div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">


<div id="elm-esk-129146639491-cyt">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>esadt.cmd.push({ render: ['esk-129146639491-cyt', 'elm-esk-129146639491-cyt', {'macro': '%%CLICK_URL_UNESC%%'}] });</script>
</div>

</div>
<p>Interior Cabinet Secretary (CS) Fred Matiang’i has detailed Deputy President William Ruto&#8217;s wealth which he says is guarded by the government.</p>
<p>The tough-speaking CS made the revelation while appearing before the National Assembly on Wednesday, September 1, 2021, to explain the recent security changes effected at the DP&#8217;s residences.</p>
<p>He was accompanied by his Principal Secretary Karanja Kibicho.</p>
<p>Matiang&#8217;i explained that the DP has hundreds of security personnel on the government&#8217;s payroll at his disposal with firm instructions to take care of him, his family, and wealth.</p>
<p>For instance, Matiang&#8217;i says the DP&#8217;s poultry farm in Eldoret is guarded by four armed officers while his gas business in Kitengela, a Nairobi suburb, has six officers.</p>
<p>At the same time, Weston Hotel, a four-star hotel with 120 rooms located in Lang&#8217;ata, a Nairobi suburb, and with an estimated value of Sh2.6 billion, has six officers permanently stationed there.</p>
<p>The government has also dispatched six officers to watch over the DP&#8217;s 15,000 hectares of land at the ADC Laikipia Ranch, and six other men in uniform to safeguard the interests at his 395-hectare farm in Trans Mara, Narok county.</p>
<p>Six other officers are permanently stationed at the DP&#8217;s 2537-acre Mata farm in Taita Taveta.</p><div class='mobile-ad' style='padding:5px;'>

<div id='div-gpt-ad-1547187122892-0'>
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547187122892-0'); });
				</script>
</div>
</div>
<p>There are five other officers located at Kwae Island Development Ltd and Wilson Airport Hangers where the second in command has reportedly stored five choppers.</p>
<p>Besides, the DP&#8217;s Elgon View Private residence and another home in the same town are guarded by four officers apiece. He maintains the security is &#8216;sufficient&#8217; for the DP.</p>
<p>&nbsp;</p>
</div>
<div class="article-content__tags">
<div class="list-tags">
<ul class="unstyled"><li><a href="https://nairobinews.nation.co.ke/tag/fred-mataiangi" rel="tag">Fred Mataiang'i</a></li><li><a href="https://nairobinews.nation.co.ke/tag/william-ruto" rel="tag">William Ruto</a></li></ul>
</div>
<div class="join-wc clearfix">
<div class="row">
<div class="grid-8 cell">
<div class="join-text">
<p>Nairobi News is now available on Telegram. For handpicked stories every day, subscribe to our channel today</p>
</div>
</div>
<div class="grid-4 cell">
<div class="join-link whats-appLink">
<a href="https://telegram.me/NairobiNews" target="_blank">
<i class="fa fa-commenting-o"></i>
<span>Telegram channel</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="stick-article-nav" class="article-content___nav">
<div class="row">
<div class="grid-4 cell">
<div class="content-nav__item prev-item">
<a href="https://nairobinews.nation.co.ke/general/copyright-board-funds-row-heads-to-court" title="Copyright board funds row heads to court">
<span class="hide-mobile">
Copyright board funds row heads to court </span>
</a>
</div>
</div>
<div class="grid-4 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;t=Matiang&#8217;i: We even guard Ruto&#8217;s chicken" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;t=Matiang&#8217;i: We even guard Ruto&#8217;s chicken" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&amp;text=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&via=Nairobi_News" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken&title=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&summary=Matiang&#8217;i: We even guard Ruto&#8217;s chicken&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
 </li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#79460a0c1b131c1a0d4434180d1018171e5f5a414b484e421043592e1c591c0f1c17591e0c180b1d592b0c0d165f5a414b484e420a591a11101a121c175f1b161d0044110d0d090a4356561718100b161b10171c0e0a5717180d101617571a1657121c56171c0e0a5614180d1018171e10540e1c541c0f1c17541e0c180b1d540b0c0d160a541a11101a121c17" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
</ul>
</div>
</div>
</div>
<div class="grid-4 cell">
<div class="content-nav__item next-item">
<a href="https://nairobinews.nation.co.ke/chillax/singer-juliani-speaks-out-on-relationship-with-lillian-nganga" title="Singer Juliani speaks out on relationship with Lillian Nganga" rel="next">
<span class="hide-mobile">
Singer Juliani speaks out on relationship with Lillian... </span>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="articles-content__author mt-40">

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.co.ke/news/matiangi-we-even-guard-rutos-chicken";
                                        _sf_async_config.title = "Matiang’i: We even guard Ruto’s chicken";
                                        _sf_async_config.sections = "Hashtag,News,What's Hot,";
                                        _sf_async_config.authors = "Hillary Kimuyu";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>


<script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "179991",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "Matiang&#8217;i: We even guard Ruto&#8217;s chicken",
                                            pubdate: "2021-09-01",
											authors: "Hillary Kimuyu",								
											sections: "Hashtag,News,What's Hot,",
                                            tags: "Fred Mataiang'i, William Ruto, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>

<br />
<div id="custom_html-22" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-0846142691248784" data-ad-slot="4659675794" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> </div>
</div>
</div>
<div class="grid-4 cell">
<div class="ad-container">
<div id="custom_html-6" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-2', [300, 250], 'div-gpt-ad-1553665892910-0').addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665892910-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665892910-0'); });
</script>
</div></div></div>
</div>
<div id="mustr-pane" class="vidoes-pane mt-20">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://nairobinews.nation.co.ke/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/lillian-nganga-unveils-mutuas-successor">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/Capture-15.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Lillian Nganga &#8216;unveils&#8217; Mutua&#8217;s successor</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/nmg-digital-platform-celebrates-first-birthday">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2021/04/NMG-180x180.jpeg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>NMG digital platform celebrates first birthday</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
 <a href="https://nairobinews.nation.co.ke/news/nmg-launch-2021-media-lab-in-partnership-with-aga-khan">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/12/Gitagama-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>NMG launch 2021 Media Lab in partnership with Aga Khan</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/general/kot-frustrated-by-harambee-stars-performance">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/10/Harambee-Stars-training-at-the-Utalii-Grounds-on-Wednesday.-Photo-courtesy-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>KOT frustrated by Harambee Stars performance</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/man-storms-ex-girlfriends-house-kills-rival">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2020/07/Handcuffs-2x-180x180.gif)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Man storms ex-girlfriend&#8217;s house, kills rival</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
 <div class="pane-box">
<a href="https://nairobinews.nation.co.ke/general/wanyama-axed-as-kenya-captain">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/07/529442-01-02-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Wanyama axed as Kenya captain</h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="ad-container">
<div id="custom_html-7" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-3', [300, 250], 'div-gpt-ad-1553665956712-0').addService(googletag.pubads());
googletag.enableServices(); });
</script>
<div id='div-gpt-ad-1553665956712-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665956712-0'); });
</script>
</div></div></div> </div>
<div id="buzz-pane" class="buzz-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/escape-room-tournament-of-champions" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1630572067.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Escape Room: Tournament of Champions</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
 <span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/the-night-house" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1629971488.png)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>The Night House</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/the-protege" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/public//uploads/posters/1629971137.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>The Protege</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/lifestyle/the-protege-movie-review-satisfyingly-entertaining" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg wp-post-image" data-bg="url(https://www.kenyabuzz.com/lifestyle/wp-content/uploads/2021/09/the-protoge-maggie-q-samuel-l-jackson-768x438.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>The Protégé Movie Review: Satisfyingly Entertaining</h3>
</div>
<div class="content-capt">
<p>The Protégé Movie Review: Satisfyingly Entertaining </p>
</div>

</div>
</a>
</div>
</div>
</div>
<div id="taboola-ads" class="taboola-ad-below-article content-sticky">

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>

</div>
</div>
</div>
</div>
</div>
<div class="smart_scroll_container" id='post-180003'></div>
</section>
</main>
<footer id="main-footer" class="mt-40" role="footer">
<div class="top-footer padt40 padb40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-4 cell">
<div class="top-footer__about">
<div class="about-logo__img">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-footer.png" alt="Nairobi News Logo" />
</div>
<div id="custom_html-20" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">Nairobi News is the most trusted website in Kenya that provides the latest breaking news, entertainment news, sports news, showbiz and celebrity stories.
will also keep you hooked with memes, gifs and funny videos.</div></span></div><div id="custom_html-21" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">
<div id='div-gpt-ad-1540468650627-0'>
<script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540468650627-0'); });
        </script>
</div> </div></span></div>

</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
 <div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Most Popular</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/chillax/singer-juliani-speaks-out-on-relationship-with-lillian-nganga"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/11/Julius-Owino-alias-Juliani.-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Julius Owino alias Juliani." data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/11/Julius-Owino-alias-Juliani.-470x264.jpg" title="Julius Owino alias Juliani." /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/chillax/singer-juliani-speaks-out-on-relationship-with-lillian-nganga">Singer Juliani speaks out on relationship with Lillian Nganga</a></h3>
</div>
<div class="content-meta">
<span class="render-text">September 1st, 2021</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/chillax/jalango-im-not-involved-in-wash-wash"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/02/Jalango-edgar-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Jalango-edgar" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/02/Jalango-edgar-470x264.jpg" title="Jalango-edgar" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/chillax/jalango-im-not-involved-in-wash-wash">Jalang&#8217;o: I&#8217;m not involved in &#8216;Wash Wash&#8217;</a></h3>
</div>
<div class="content-meta">
<span class="render-text">August 30th, 2021</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/celebrated-journalist-ben-kitili-rejoins-ntv"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/11/Kitili-Amina-V-74x55.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Kitili-Amina-V" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/11/Kitili-Amina-V.jpg" title="Kitili-Amina-V" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/celebrated-journalist-ben-kitili-rejoins-ntv">Celebrated journalist Ben Kitili rejoins NTV</a></h3>
</div>
<div class="content-meta">
<span class="render-text">August 27th, 2021</span>
</div>
</div>
</div>
</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Don't Miss</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/lillian-nganga-unveils-mutuas-successor"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/Capture-15-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Capture" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/Capture-15.jpg" title="Capture" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/lillian-nganga-unveils-mutuas-successor">Lillian Nganga &#8216;unveils&#8217; Mutua&#8217;s successor</a></h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/nmg-digital-platform-celebrates-first-birthday"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2021/04/NMG-150x150.jpeg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="NMG" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2021/04/NMG-470x264.jpeg" title="NMG" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/nmg-digital-platform-celebrates-first-birthday">NMG digital platform celebrates first birthday</a></h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/nmg-launch-2021-media-lab-in-partnership-with-aga-khan"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/12/Gitagama-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Gitagama" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2020/12/Gitagama-470x264.jpg" title="Gitagama" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/nmg-launch-2021-media-lab-in-partnership-with-aga-khan">NMG launch 2021 Media Lab in partnership with Aga Khan</a></h3>
</div>
<div class="content-meta">
<span class="render-text">September 3rd, 2021</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-footer text-center padt20 padb20">
<span class="render-text">
Copyright &copy; 2021 Nation Media Group. All rights reserved.
</span>
</div>
</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/plugins.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript">
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#!'+id;
          window.history.pushState({path:newurl},'',newurl);
		  //alert(id);
      }
    }
</script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-includes/js/wp-embed.min.js'></script>



<iframe name="__bkframe" height="0" width="0" frameborder="0" style="display:none;position:absolute;clip:rect(0px 0px 0px 0px)" src="about:blank"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script type="text/javascript">
bk_allow_multiple_calls=true;
bk_meta_vars=[];
bk_doJSTag(80213, 1);
</script>

<script src="https://d35ul1o6ah7bnm.cloudfront.net/africa/sdk/justslide.min.js" async="async"></script>
<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

	ga('create', 'UA-1030601-4', 'auto');
	ga(function(tracker) {
	  justslide.configure(42, 'UA-1030601-4', tracker.get('clientId'));
	  justslide.pageview();
	});
</script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'68901eed1e655a16',m:'FdzOezz7y0s9UPOuHIc4dPPIJppYkqEI8ph1JhL3gvA-1630684095-0-ASkTUq93F2IQcurRoqRpO2oJk2FGnBX1vmI+nokhdzUwWeEzTSqfz9kVQ7zDWJg8uln89X8bpnwNr+XYB/8DxMHThNzB+k3WPy5wl0xj7rd+qg00XXVJFPQfHHx6Kj3DDHQdOCxuYf/lPMusVNyGA8nAt3KP1GFoGxH2j3J3uJx+',s:[0xa922f0b78f,0xa8f331d983],}})();</script></body>
</html>