<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta name="theme-color" content="#F0F0F0">
<meta name="msapplication-TileColor" content=#F0F0F0>
<meta property="og:locale" content="en_GB">
<meta property="og:locale:alternate" content="en_US">
<meta property="og:type" content="website" />
<meta name="robots" content="index,follow">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="copyright" content="Nation Media Group">
<link rel="manifest" href="https://nairobinews.nation.co.ke/manifest.json">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" />
<link rel="amphtml" href="https://nairobinews.nation.co.ke/amp/hashtag/lawyer-assa-nyakundi-arrested">
<link rel="shortcut icon" type="image/x-icon" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon.ico">
<link rel="icon" type="image/png" sizes="32x32" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-64x64.png">
<link rel="icon" type="image/png" sizes="24x24" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-24x24.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-16x16.png">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/css/main_v2.css?v=2">
<title>Lawyer Assa Nyakundi arrested by detectives &#8211; Nairobi News</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.co.ke/feed" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.co.ke/comments/feed" />
<meta property="og:title" content="Lawyer Assa Nyakundi arrested by detectives" />
<meta property="og:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" />
<meta property="og:site_name" content="Nairobi News" />
<meta property="og:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Assa-Nyakundi-III.jpg" />
<meta name="keywords" content="Assa Nyakundi,murder," />
<meta property="fb:app_id" content="119242211439858" />
<meta property="fb:pages" content="497615353664351" />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2019-06-19 16:16:12" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Nairobi_News" />
<meta name="twitter:title" content="Lawyer Assa Nyakundi arrested by detectives" />
<meta name="twitter:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta name="twitter:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Assa-Nyakundi-III.jpg" />
<meta name="twitter:url" content="https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nairobinews.nation.co.ke\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='_nn_clean-style-css' href='https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/style.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://nairobinews.nation.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.9" />
<link rel="canonical" href="https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" />
<link rel='shortlink' href='https://nairobinews.nation.co.ke/?p=151031' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Flawyer-assa-nyakundi-arrested" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Flawyer-assa-nyakundi-arrested&#038;format=xml" />


<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-4');
    </script>


<script type="text/javascript">
        _atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.co.ke",dynamic: true};
        (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
    </script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
		  googletag.cmd.push(function() {
			googletag.defineOutOfPageSlot('/1010816/NN-Profit-Button', 'div-gpt-ad-1560489456971-0').addService(googletag.pubads());
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		  });
		</script>

<div id='div-gpt-ad-1560489456971-0'>
<script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560489456971-0'); });
        </script>
</div>
<script type="text/javascript">
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
                document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
                'tb_loader_script');
        </script>
<script type="text/javascript">
        var _sf_async_config = _sf_async_config || {};
        /** CONFIGURATION START **/
        _sf_async_config.uid = 63208; // ACCOUNT NUMBER
        _sf_async_config.domain = 'nairobinews.nation.co.ke'; // DOMAIN
        _sf_async_config.flickerControl = false;
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = false;
        /** CONFIGURATION END **/
        var _sf_startpt = (new Date()).getTime();
    </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />
</head>
<body class="inner-body">
<div id="content_overlay"></div>
<div id="mp-menu" class="mp-menu">
<div class="mp-level">
<div class="mp-level-scroll">
<div class="search-form">
<div class="form-container posRelative">

<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
<ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> <div class="whats-appLink">
<div class="title">Join our WhatsApp Channel</div>
<a href="javascript:void(0);">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp</span>
</a>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<span class="title">Connect with us</span>
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>

</ul>
</div>
</div>
</div>
</div>
</div>
<div id="top-section">
<header id="main-header" class="clearfix">
<div class="row">
<div class="row">
<div class="grid-2 cell">
<div class="site-branding">
<h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
<div class="site-logo mobile-hidden">
<a href="https://nairobinews.nation.co.ke/?"><img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
</div>
</div>
</div>
<div class="grid-10 cell">
<div class="ad-container nobg">
<div id="custom_html-26" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div> </div>
</div>
</div>
</div>
<div id="mobile-menu" class="mobile-menu web-hidden">
<div class="row">
<div class="row">
<div class="grid-6 cell">
<div class="site-logo">
<a href="https://nairobinews.nation.co.ke">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-black.svg" alt="Nairobi News Logo" />
</a>
</div>
</div>
<div class="grid-6 cell">
<div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
<div class="line-menu"></div>
<div class="line-menu"></div>
<div class="line-menu"></div>
</div>
</div>
</div>
</div>
</div>
</header>
<nav id="main-navigation" class="main-nav clearfix" role="nav">
<div class="content">
<div class="row">
<div class="nav-left">
<ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> </div>
<div class="nav-right">
<div id="search-show" class="right-search">
<div class="right-search__icon search-close">
<span class="fa fa-search"></span>
</div>
<div class="search-form">
<div class="form-container">
<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
</div>
 <div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>
<li id="alerts" class="alert close">
<a href="javascript:void(0);" title="Updates made in the last 20 minutes">
<span class="alert-num">
0 </span>
<i class="fa fa-bell"></i>
<span class="hide">Alerts</span>
</a>
</li>
</ul>
</div>
</div>
<div id="dropdown-latest" class="dropdown-item">
<div class="dropdown-content">

</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<main id="main-content" role="content"> <main id="main-content" role="content">
<section id="single-content" class="single-content mt-40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-8 cell">
<div class="single-container">
<div class="article-content">
<div class="article-content__top">
<div class="content-top__title">
<span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/hashtag">Hashtag</a></span><span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/news">News</a></span> <h2>Lawyer Assa Nyakundi arrested by detectives</h2>
</div>
<div class="content-top__meta mt-20 clearfix">
<div class="row">
<div class="grid-6 cell">
<div class="meta-articles__details">
<div class="meta-avatar">
<div class="avatar-content">
<div class="avatar-content__img wp-post-image" data-bg="url()"></div>
</div>
</div>
<div class="meta-details">
<div class="meta-author">
<span class="render-text by">
<span class="mr-5">By</span>
<a href="javascript:void(0);" role="author">
Nyaboga Kiage</a></span>
<span>June 19th, 2019 <i class="dot"></i> 1 min read</span>
</div>
</div>
</div>
</div>
<div class="grid-6 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li>
<span>Share this</span>
</li>
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;t=Lawyer Assa Nyakundi arrested by detectives" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;t=Lawyer Assa Nyakundi arrested by detectives" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;text=Lawyer Assa Nyakundi arrested by detectives" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&title=Lawyer Assa Nyakundi arrested by detectives&summary=Lawyer Assa Nyakundi arrested by detectives&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#605f1315020a0503145d2c01171905124021131301402e19010b150e0409400112120513140504400219400405140503140916051346020f04195d08141410135a4f4f0e0109120f02090e0517134e0e0114090f0e4e030f4e0b054f0e0517134f0c01171905124d011313014d0e19010b150e04094d0112120513140504" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
<li class="email" style="display: none;">
<a href="javascript:void(0);" id="#work" title="Share this via PWA" style="display: none;">
<i class="fa fa-share-alt"></i>
<span class="hide">Share this via PWA</span>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="article-content__banner">
<div class="banner-container">
<div class="banner-image">
<img width="1320" height="743" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Assa-Nyakundi-III-150x150.jpg" class="attachment-single-image size-single-image wp-post-image" alt="Assa-Nyakundi-III" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Assa-Nyakundi-III-470x264.jpg" title="Assa-Nyakundi-III" /> </div>
<div class="banner-caption">

<span class="render-text">Lawyer Assa Nyakundi at Makadara Law Courts in Nairobi on Thursday, April 25, 2019. PHOTO | DENNIS ONSONGO
</span> </div>
</div>
</div>
<div class="article-content__content clearfix mt-40">
<div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
											googletag.cmd.push(function() {
											googletag.defineSlot('/1010816/NN-ARTICLE-4', [300, 250], 'div-gpt-ad-1553666013837-0').addService(googletag.pubads());
											googletag.enableServices(); });
											</script>
<div id='div-gpt-ad-1553666013837-0' style='height:250px; width:300px;'>
<script>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553666013837-0'); });
											</script>
</div>
<br />
</div>
<p>Lawyer Assa Nyakundi has been arrested by detectives attached to the Directorate of Criminal Investigations (DCI).</p>
<p>Mr Nyakundi, who is out on bond in case involving the murder of his son, was arrested as he walked out of his office in Kileleshwa.</p><div class="other-stories related-content clearfix"><div class="grid-12 cell"><h3>OTHER ARTICLES</h3></div><div class="row"><ul><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/editors-picks/ig-introduces-minor-changes-to-mounting-of-police-road-blocks><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/04/Hillary-Mutyambai-150x150.jpg" /></span><span class="related-content__text">IG introduces minor changes to mounting of police road blocks</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/chillax/wema-sepetu-sex-video-ex-boyfriend><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Wema-and-PCK-150x150.jpg" /></span><span class="related-content__text">Wema Sepetu gets sympathy from sex video ex-boyfriend</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/news/three-found-guilty-of-garissa-university-attack><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-150x150.jpg" /></span><span class="related-content__text">Three found guilty of Garissa University terror attack</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/news/anne-waiguru-kamotho-waiganjo-traditional-wedding-set-for-july><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/ANne-Waiganjo-150x150.jpg" /></span><span class="related-content__text">Anne Waiguru-Kamotho Waiganjo traditional wedding set for July</span></a></li></div></ul></div></div>
<p>Mr Nyakundi is being represented by senior lawyer Mr John Khaminwa.</p>
<p>Detectives told <em>Nairobi News</em> that the arrest is linked to the ongoing case against him.</p>
<p>“This is in line with the ongoing case, his file will be reviewed and the charges tabled as murder and not manslaughter,” the detective said.</p>
<p>His arrest came just hours after Kiambu High Court Judge Christine Meoli excused herself from hearing the case against the lawyer citing conflict of interest as they were once classmates.</p>
<p><em><strong>More to follow&#8230;</strong></em></p>
<div class='mobile-ad' style='padding:5px;'>

<div id='div-gpt-ad-1547187122892-0'>
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547187122892-0'); });
				</script>
</div>
</div> </div>
<div class="article-content__tags">
<div class="list-tags">
<ul class="unstyled"><li><a href="https://nairobinews.nation.co.ke/tag/assa-nyakundi" rel="tag">Assa Nyakundi</a></li><li><a href="https://nairobinews.nation.co.ke/tag/murder" rel="tag">murder</a></li></ul>
</div>
<div class="join-wc clearfix">
<div class="row">
<div class="grid-8 cell">
<div class="join-text">
<p>Nairobi News is now available on WhatsApp. For handpicked stories every day, subscribe to our</p>
</div>
</div>
<div class="grid-4 cell">
<div class="join-link whats-appLink">
<a href="https://wb.messengerpeople.com/?widget_hash=0cda75ec47718042f9c019db68d3f6e4&lang=en&wn=0" target="_blank">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp channel</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="stick-article-nav" class="article-content___nav">
<div class="row">
<div class="grid-4 cell">
<div class="content-nav__item prev-item">
<a href="https://nairobinews.nation.co.ke/hustle/conserving-nature-pencils-old-newspapers" title="Conserving nature with pencils made from old newspapers &#8211; VIDEO">
<span class="hide-mobile">
Conserving nature with pencils made from old newspapers... </span>
</a>
</div>
</div>
<div class="grid-4 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;t=Lawyer Assa Nyakundi arrested by detectives" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;t=Lawyer Assa Nyakundi arrested by detectives" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&amp;text=Lawyer Assa Nyakundi arrested by detectives" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested&title=Lawyer Assa Nyakundi arrested by detectives&summary=Lawyer Assa Nyakundi arrested by detectives&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#c2fdb1b7a0a8a7a1b6ff8ea3b5bba7b0e283b1b1a3e28cbba3a9b7aca6abe2a3b0b0a7b1b6a7a6e2a0bbe2a6a7b6a7a1b6abb4a7b1e4a0ada6bbffaab6b6b2b1f8ededaca3abb0ada0abaca7b5b1ecaca3b6abadaceca1adeca9a7edaca7b5b1edaea3b5bba7b0efa3b1b1a3efacbba3a9b7aca6abefa3b0b0a7b1b6a7a6" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
</ul>
</div>
</div>
 </div>
<div class="grid-4 cell">
<div class="content-nav__item next-item">
<a href="https://nairobinews.nation.co.ke/featured/banki-benki-new-banknotes" title="Banki or Benki? Opinion divided over new banknotes" rel="next">
<span class="hide-mobile">
Banki or Benki? Opinion divided over new banknotes </span>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="articles-content__author mt-40">
<div class="about-title">
<div class="about-title__content">
<h2>About the author</h2>
</div>
</div>
<div class="author-content clearfix mt-20">

<div class="author-details">
<h3>Nyaboga Kiage</h3>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.co.ke/news/lawyer-assa-nyakundi-arrested";
                                        _sf_async_config.sections = "Hashtag,News,";
                                        _sf_async_config.authors = "Nyaboga Kiage";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>


<script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "151031",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "Lawyer Assa Nyakundi arrested by detectives",
                                            pubdate: "2019-06-19",
											authors: "Nyaboga Kiage",								
											sections: "Hashtag,News,",
                                            tags: "Assa Nyakundi, murder, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>

<br />
<div id="custom_html-22" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-0846142691248784" data-ad-slot="4659675794" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> </div>
<div class="articles-content__related mt-40">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Also read</a>
</h2>
</div>
</div>
</div>
<div id="trending-pane" class="posRelative mobile-full">
<div class="row">
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/three-found-guilty-of-garissa-university-attack">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-150x150.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="DnGarissaAttack0304pg" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-470x264.jpg" title="DnGarissaAttack0304pg" /> </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Three found guilty of Garissa University terror attack</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/anne-waiguru-kamotho-waiganjo-traditional-wedding-set-for-july">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/ANne-Waiganjo-150x150.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="ANne Waiganjo" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/ANne-Waiganjo-470x264.jpg" title="ANne Waiganjo" /> </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Anne Waiguru-Kamotho Waiganjo traditional wedding set for July</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/private-car-owners-to-pay-sh3-5k-inspection-fees-in-proposed-rules">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/11/Thika-road-traffic-74x55.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="Thika-road-traffic" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/11/Thika-road-traffic.jpg" title="Thika-road-traffic" /> </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Private car owners to pay Sh3.5k inspection fees in proposed rules</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="taboola-ads" class="taboola-ad-below-article">

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>

</div>
</div>
</div>
<div class="grid-4 cell">
<div class="ad-container">
<div id="custom_html-6" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-2', [300, 250], 'div-gpt-ad-1553665892910-0').addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665892910-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665892910-0'); });
</script>
</div></div></div> 
</div>
<div id="mustr-pane" class="vidoes-pane mt-20">
 <div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://nairobinews.nation.co.ke/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/ig-introduces-minor-changes-to-mounting-of-police-road-blocks">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/04/Hillary-Mutyambai-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>IG introduces minor changes to mounting of police road...</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/chillax/wema-sepetu-sex-video-ex-boyfriend">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Wema-and-PCK-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Wema Sepetu gets sympathy from sex video ex-boyfriend</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/three-found-guilty-of-garissa-university-attack">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Three found guilty of Garissa University terror attack</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/anne-waiguru-kamotho-waiganjo-traditional-wedding-set-for-july">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/ANne-Waiganjo-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Anne Waiguru-Kamotho Waiganjo traditional wedding set for...</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/nairobi-human-right-activists-arrested">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Sudan-Demo-xx-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Nairobi Human right activists teargased, arrested in...</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/police-officer-sharing-pictures-blogger-arrested">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/01/EAHandcuffs2.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Police officer suspected of sharing gory pictures with...</h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="ad-container">
<div id="custom_html-7" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-3', [300, 250], 'div-gpt-ad-1553665956712-0').addService(googletag.pubads());
googletag.enableServices(); });
</script>
<div id='div-gpt-ad-1553665956712-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665956712-0'); });
</script>
</div></div></div> </div>
<div id="vidoes-pane" class="vidoes-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<div class="pane-title-label">
<a href="https://nairobinews.nation.co.ke/gallery/">Watch<i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img posRelative">
<a data-fancybox="" href="https://www.youtube.com/embed/N91AV6RYvMM?rel=0?autoplay=0" target="_blank">
<div class="play-video__btn" onclick="updateURL('videos/watch-sonko-caught-on-camera-slapping-man-in-public');">
<div class="centered">
<div class="centeredInner">
<i class="fa fa-play"></i>
</div>
</div>
</div>
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Sonko-Slapping-180x180.jpg)"></div>
</a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/videos/watch-sonko-caught-on-camera-slapping-man-in-public">WATCH: Sonko caught on camera slapping man in public</a></h3>
</div>
<div class="content-meta">
 
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img posRelative">
<a data-fancybox="" href="https://www.youtube.com/embed/0MejP3svWBI?rel=0?autoplay=0" target="_blank">
<div class="play-video__btn" onclick="updateURL('videos/shaffie-adelle-shown-the-door-at-kiss-100-to-make-way-for-kamene-and-kibe');">
<div class="centered">
<div class="centeredInner">
<i class="fa fa-play"></i>
</div>
</div>
</div>
<div class="img-boxbg wp-post-image" data-bg="url()"></div>
</a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/videos/shaffie-adelle-shown-the-door-at-kiss-100-to-make-way-for-kamene-and-kibe">Shaffie, Adelle shown the door at Kiss 100 to make way for...</a></h3>
</div>
<div class="content-meta">

</div>
</div>
</div>
</div>
</div>
<div id="gallery-pane" class="gallery-pane mt-20">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<div class="pane-title-label">
<a href="https://nairobinews.nation.co.ke/gallery/">Photo Gallery<i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/nairobi-jam-with-serro">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/NN-Serro-b-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">6</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Sights from &#8216;Nairobi Jam with Serro&#8217;</h3>
</div>
<div class="content-meta">

</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/men-in-black-international-premieres-in-nairobi">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/NN-Men-in-Black-2-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">5</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Men in Black: International premieres in Nairobi</h3>
</div>
<div class="content-meta">

</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/jazz-by-classically-christine">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/NN-Christine-b-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">7</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Jazz by Classically Christine</h3>
</div>
<div class="content-meta">

</div>
</div>
</a>
</div>
</div>
</div>
<div id="buzz-pane" class="buzz-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/godzilla-king-of-the-monsters" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://image.tmdb.org/t/p/w342//pU3bnutJU91u3b4IeRPQTOP8jhV.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Godzilla: King of the Monsters</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/captain-marvel" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://image.tmdb.org/t/p/w342//vW2dy7UyZqqpEP3bHageT9bei0o.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Captain Marvel</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/events/event/2nd-annual-global-mice-summit" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://www.kenyabuzz.com/public/uploads/events/a7753c3088f6133aa4b69f12c0d149f9.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>2nd Annual Global Mice Summit</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/events/event/mma-june-2019" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://www.kenyabuzz.com/public//uploads/posters/1558352909.png)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>MMA July 2019</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
</main>
<footer id="main-footer" class="mt-40" role="footer">
<div class="top-footer padt40 padb40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-4 cell">
<div class="top-footer__about">
<div class="about-logo__img">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-footer.png" alt="Nairobi News Logo" />
</div>
<div id="custom_html-20" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">Nairobi News is the most trusted website in Kenya that provides the latest breaking news, entertainment news, sports news, showbiz and celebrity stories.
will also keep you hooked with memes, gifs and funny videos.</div></span></div><div id="custom_html-21" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">
<div id='div-gpt-ad-1540468650627-0'>
<script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540468650627-0'); });
        </script>
</div> </div></span></div>

</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Most Popular</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/life/billionaire-manu-chandaria-opens-up-on-his-64-year-marriage"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Untitled-1-2-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Untitled-1" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Untitled-1-2-470x264.jpg" title="Untitled-1" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/life/billionaire-manu-chandaria-opens-up-on-his-64-year-marriage">Billionaire Manu Chandaria opens up on his 64-year marriage</a></h3>
</div>
<div class="content-meta">
<span class="render-text">June 15th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/featured/broke-kenyans-beg-saumu-mbuvi-for-help-after-she-flaunts-pile-of-cash"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Saumu-Mbuvi-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Saumu-Mbuvi" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Saumu-Mbuvi-470x264.jpg" title="Saumu-Mbuvi" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/featured/broke-kenyans-beg-saumu-mbuvi-for-help-after-she-flaunts-pile-of-cash">Broke Kenyans beg Sonko&#8217;s daughter for help after she flaunts pile of cash</a></h3>
</div>
<div class="content-meta">
<span class="render-text">June 15th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/life/boys-dirty-talk-woman"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Child-Woman-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Child-Woman" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Child-Woman-470x264.jpg" title="Child-Woman" /></a>
</div>
 <div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/life/boys-dirty-talk-woman">Shocking video of young boy&#8217;s &#8216;dirty talk&#8217; with woman goes viral</a></h3>
</div>
<div class="content-meta">
<span class="render-text">June 18th, 2019</span>
</div>
</div>
</div>
</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Don't Miss</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/editors-picks/ig-introduces-minor-changes-to-mounting-of-police-road-blocks"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/04/Hillary-Mutyambai-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Hillary-Mutyambai" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/04/Hillary-Mutyambai-470x264.jpg" title="Hillary-Mutyambai" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/editors-picks/ig-introduces-minor-changes-to-mounting-of-police-road-blocks">IG introduces minor changes to mounting of police road blocks</a></h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/chillax/wema-sepetu-sex-video-ex-boyfriend"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Wema-and-PCK-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Wema-and-PCK" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/Wema-and-PCK-470x264.jpg" title="Wema-and-PCK" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/chillax/wema-sepetu-sex-video-ex-boyfriend">Wema Sepetu gets sympathy from sex video ex-boyfriend</a></h3>
</div>
<div class="content-meta">
 <span class="render-text">June 19th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/three-found-guilty-of-garissa-university-attack"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="DnGarissaAttack0304pg" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/06/DnGarissaAttack0304pg-470x264.jpg" title="DnGarissaAttack0304pg" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/three-found-guilty-of-garissa-university-attack">Three found guilty of Garissa University terror attack</a></h3>
</div>
<div class="content-meta">
<span class="render-text">June 19th, 2019</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-footer text-center padt20 padb20">
<span class="render-text">
Copyright &copy; 2019 Nation Media Group. All rights reserved.
</span>
</div>
</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/plugins.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript">
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#!'+id;
          window.history.pushState({path:newurl},'',newurl);
		  //alert(id);
      }
    }
</script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-includes/js/wp-embed.min.js'></script>


</body>
</html>