 <!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" class="no-js">
<head>
<title>
		Fake handshake? Kenyans taunt Raila on Miguna&#039;s airport drama - Nairobi News	  	</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no">
<meta property="fb:pages" content="497615353664351" />
<meta property="fb:use_automatic_ad_placement" content="true">
<script src="/cdn-cgi/apps/head/gkOpMIfXCsXHxuXmenyCEA-mOmA.js"></script><link rel="pingback" href="https://nairobinews.nation.co.ke/xmlrpc.php" />

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-1030601-4', 'auto');
ga('send', 'pageview');
</script>


<script type='text/javascript'>
	  (function() {
		var useSSL = 'https:' == document.location.protocol;
		var src = (useSSL ? 'https:' : 'http:') +
			'//www.googletagservices.com/tag/js/gpt.js';
		document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
	  })();
	</script>

<script type='text/javascript'>
	  googletag.cmd.push(function() {
	    googletag.defineSlot('/1010816/NN-300x250-3', [300, 250], 'div-gpt-ad-1467179851519-0').addService(googletag.pubads());
	    googletag.pubads().enableSingleRequest();
	    googletag.enableServices();
	  });
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-300x250-article-2', [300, 250], 'div-gpt-ad-1508224212141-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-Home-300x250-1', [300, 250], 'div-gpt-ad-1448278837995-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  googletag.cmd.push(function() {
                var leaderBoard = googletag.sizeMapping().   
    addSize([1024, 0], [728, 90]).
    addSize([600, 0], [468, 60]).
    addSize([800, 0], [728, 90]).
    addSize([0, 0], [300, 100]).
    build();
    googletag.defineSlot('/1010816/NN-728x90-1', [[468, 60], [300, 100], [728, 90]], 'div-gpt-ad-1516968525831-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  googletag.cmd.push(function() {
                var leaderBoard = googletag.sizeMapping().   
    addSize([1024, 0], [728, 90]).
    addSize([600, 0], [468, 60]).
    addSize([800, 0], [728, 90]).
    addSize([0, 0], [300, 100]).
    build();
    googletag.defineSlot('/1010816/NN-728x90-Inside-1', [[300, 100], [728, 90], [468, 60]], 'div-gpt-ad-1516968150773-0').defineSizeMapping(leaderBoard).addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-728x90-sports-1', [728, 90], 'div-gpt-ad-1469107478851-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-300x250-article-1', [300, 250], 'div-gpt-ad-1508224286301-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-300x250-sports-1', [300, 250], 'div-gpt-ad-1469100473222-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script type='text/javascript'>
	  googletag.cmd.push(function() {
		googletag.defineSlot('/1010816/NN-300x250-Home-2', [300, 250], 'div-gpt-ad-1449730318550-0').addService(googletag.pubads());
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();
	  }); 
	</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-Expandable-Test', [950, 65], 'div-gpt-ad-1480089141956-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.pubads().enableSyncRendering();
    googletag.enableServices();
  });
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-300x250-incontent', [300, 250], 'div-gpt-ad-1471526621593-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1010816/NN-320x100-m-incontent', [[320, 100], [320, 50]], 'div-gpt-ad-1490015341461-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>
<!--[if lt IE 9]>
		<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
		<![endif]-->
<script type="text/javascript">
			document.write('<style>.noscript { display: none; }</style>');
			window.location.template_uri = 'https://nairobinews.nation.co.ke/wp-content/themes/nairobinews';
		</script>

<link rel="canonical" href="https://nairobinews.nation.co.ke/news/fake-handshake/" />
<link rel="publisher" href="https://plus.google.com/u/0/113863105291971720056/posts" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Fake handshake? Kenyans taunt Raila on Miguna&#039;s airport drama - Nairobi News" />
<meta property="og:description" content="Kenyans on Twitter have been taunting Nasa leader Raila Odinga over his unity handshake with President Uhuru Kenyatta" />
<meta property="og:url" content="https://nairobinews.nation.co.ke/news/fake-handshake/" />
<meta property="og:site_name" content="Nairobi News" />
<meta property="article:publisher" content="https://www.facebook.com/NairobiNewsKE" />
<meta property="article:tag" content="#FakeHandshake" />
<meta property="article:tag" content="JKIA" />
<meta property="article:tag" content="Miguna Miguna" />
<meta property="article:tag" content="Raila Odinga" />
<meta property="article:tag" content="Twitter" />
<meta property="article:section" content="Also Featured" />
<meta property="article:published_time" content="2018-03-27T08:36:48+03:00" />
<meta property="article:modified_time" content="2018-03-27T09:12:40+03:00" />
<meta property="og:updated_time" content="2018-03-27T09:12:40+03:00" />
<meta property="fb:app_id" content="497615353664351" />
<meta property="og:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff.jpg" />
<meta property="og:image:width" content="524" />
<meta property="og:image:height" content="350" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Kenyans on Twitter have been taunting Nasa leader Raila Odinga over his unity handshake with President Uhuru Kenyatta" />
<meta name="twitter:title" content="Fake handshake? Kenyans taunt Raila on Miguna&#039;s airport drama - Nairobi News" />
<meta name="twitter:site" content="@Nairobi_News" />
<meta name="twitter:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff.jpg" />
<meta name="twitter:creator" content="@Nairobi_News" />

<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.co.ke/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.co.ke/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"https:\/\/nairobinews.nation.co.ke\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.2"}};
			!function(a,b,c){function d(a){var c,d=b.createElement("canvas"),e=d.getContext&&d.getContext("2d"),f=String.fromCharCode;return e&&e.fillText?(e.textBaseline="top",e.font="600 32px Arial","flag"===a?(e.fillText(f(55356,56806,55356,56826),0,0),d.toDataURL().length>3e3):"diversity"===a?(e.fillText(f(55356,57221),0,0),c=e.getImageData(16,16,1,1).data.toString(),e.fillText(f(55356,57221,55356,57343),0,0),c!==e.getImageData(16,16,1,1).data.toString()):("simple"===a?e.fillText(f(55357,56835),0,0):e.fillText(f(55356,57135),0,0),0!==e.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='nairobi-css' href='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/css/nairobi.css?ver=0.12' type='text/css' media='all' />
<link rel='stylesheet' id='widg-css' href='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/css/widg.css?ver=0.01' type='text/css' media='all' />
<link rel='stylesheet' id='galleriffic-css' href='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/css/galleriffic-5.css?ver=0.02' type='text/css' media='all' />
<link rel='stylesheet' id='bmsils-css' href='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/css/bmsils.css?ver=0.01' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-gallery-css' href='https://nairobinews.nation.co.ke/wp-content/plugins/youtube-channel-gallery/styles.css?ver=4.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.magnific-popup-css' href='https://nairobinews.nation.co.ke/wp-content/plugins/youtube-channel-gallery/magnific-popup.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery-1.8.2.min.js?ver=1.8.2'></script>
<link rel='https://api.w.org/' href='https://nairobinews.nation.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.4.2" />
<link rel='shortlink' href='https://nairobinews.nation.co.ke/?p=116104' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Ffake-handshake%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Fnews%2Ffake-handshake%2F&#038;format=xml" />
</head>
<body itemscope="itemscope" itemtype="http://schema.org/WebPage" onload="loadXMLDoc()">
<div id="wrapper">
<div id="pagewrap">
<div class="fixedheader"></div>
<header>
<div class="sheader-masthead">
<div class="row-masthead">
<div class="container-masthead desktop-masthead">
<div class="col-masthead">
<div class="col1-masthead"><a href="https://nairobinews.nation.co.ke"><img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/nn.png" alt="" /></a></div>

</div>
<div class="col-masthead cgirl-masthead">
<div class="headerads">
<div class="wrap-ad">

<div id='div-gpt-ad-1516968150773-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1516968150773-0'); });
</script>
</div>


</div>
</div>
</div>
</div>

<div class="container-masthead mobile-masthead">
<div class="row-fluid-masthead">
<div class="col1-masthead"><a href="https://nairobinews.nation.co.ke"><img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/nn.png" alt="" /></a></div>

<div class="col3-masthead">
<div class="social-masthead">
<span><span class="likes-masthead"></span><a href="https://www.facebook.com/NairobiNewsKE"><img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/fb.jpg" width="38" height="38" alt="" /></a></span>
<span><span class="likes-masthead">351K</span><a href="https://www.facebook.com/NairobiNewsKE"><img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/fb.jpg" width="38" height="38" alt="" /></a></span>
<a href="https://nairobinews.nation.co.ke/category/news/feed/"><span><img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/rss.jpg" width="38" height="38" alt="" /></span></a>
</div>
</div>
</div>
<div class="row-fluid-masthead cgirl-masthead">
<div class="row-fluid-masthead cityg-masthead">
</div>
<div class="sfield-masthead">
<form role="search" method="post" id="input-box" action="https://nairobinews.nation.co.ke">
<input name="s" id="s" type="text" class="input-box-masthead" value="" placeholder="Type and hit Enter" />
<input name="" type="submit" value="" class="sbtn-masthead" />
</form>
</div>
</div>

</div>
</div></div>
<aside class="side-bar">

<a class="nav_icon" href="#"></a>
<nav class="top-navigation"><ul id="main-menu" class=""><li id="menu-item-27" class="menu-home menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a title="Home" href="https://nairobinews.nation.co.ke/">HOME</a></li>
<li id="menu-item-11" class="menu-top-news menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a title="Top News" href="https://nairobinews.nation.co.ke/category/news/">TOP NEWS</a></li>
<li id="menu-item-14822" class="menu-sports menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14822"><a title="sports" href="https://nairobinews.nation.co.ke/category/sports/">SPORTS</a></li>
<li id="menu-item-9" class="menu-life menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9"><a title="Life" href="https://nairobinews.nation.co.ke/category/life/">LIFE</a></li>
<li id="menu-item-7" class="menu-chillax menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7"><a title="Chillax" href="https://nairobinews.nation.co.ke/category/chillax/">CHILLAX</a></li>
<li id="menu-item-6" class="menu-blog menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6"><a title="Blog" href="https://nairobinews.nation.co.ke/category/blog/">BLOG</a></li>
<li id="menu-item-15648" class="menu-tv menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15648"><a title="tv" href="https://nairobinews.nation.co.ke/category/tv/">VIDEOS</a></li>
<li id="menu-item-17" class="menu-gallery menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a title="Gallery" href="https://nairobinews.nation.co.ke/gallery/">GALLERY</a></li>
<li id="menu-item-8" class="menu-jobs menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8"><a title="Jobs" href="https://nairobinews.nation.co.ke/category/jobs/">BIZ</a></li>
</ul></nav> </aside>


<div class="news-block">
<ul id="newsticker_demo_scroll" class="newsticker">
<li><a href="https://nairobinews.nation.co.ke/news/sonko-yet-impress-nairobians-theyre-letting-know/">Sonko yet to impress Nairobians and they&#8217;re letting him know</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/raila-sue-cambridge-analytica-facebook-propaganda/">Raila to sue Cambridge Analytica, Facebook for propaganda</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/police-lock-down-jkia-terminal-as-miguna-refuses-to-sign-citizenship-papers-photos/">Police lock down JKIA terminal as Miguna refuses to sign citizenship papers &#8211; PHOTOS</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/survey-nairobi-tycoons-now-control-86-per-cent-citys-wealth/">SURVEY: Nairobi tycoons now control 86 per cent of city&#8217;s wealth</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/state-gives-deportation-bid-offers-miguna-citizenship-papers/">State gives up deportation bid, offers Miguna citizenship papers</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/fake-handshake/">Fake handshake? Kenyans taunt Raila on Miguna&#8217;s airport drama</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/itumbi-cheers-police-attack-journalists-jkia-photos-videos/">State House director cheers police attack on journalists at JKIA – PHOTOS, VIDEOS</a></li>
<li><a href="https://nairobinews.nation.co.ke/news/city-researcher-wants-mps-legalise-bhang/">Why this city researcher wants MPs to legalise bhang</a></li>
</ul>
</div> <div class="row-fluid-masthead">
<div class="sfield-masthead">
<form role="search" method="post" id="input-box" action="https://nairobinews.nation.co.ke">
<input name="s" id="s" type="text" class="input-box-masthead" value="" placeholder="Type and hit Enter" />
<input name="" type="submit" value="" class="sbtn-masthead" />
</form>
</div>

</div>
<script type="text/javascript">
			window._taboola = window._taboola || [];
			_taboola.push({article:'auto'});
			!function (e, f, u, i) {
				if (!document.getElementById(i)){
					e.async = 1;
					e.src = u;
					e.id = i;
					f.parentNode.insertBefore(e, f);
				}
			}(document.createElement('script'),
					document.getElementsByTagName('script')[0],
					'//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
					'tb_loader_script');
		</script>
</header>


<link href="//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.1.0/css/font-awesome.min.css" rel="stylesheet">


<script src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery.ajax-cross-origin.min.js"></script>


<script src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/share-button.min.js"></script>

<link href="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/ibacor-sosmed-button.css" rel="stylesheet">

<style>
	
			.ss_sharebar .email-print-holder{
				display: inline-block;
				float: right;
				padding: 0;
			}
			.ss_sharebar .sh-print-email {
				background: #ddd;
				color: #333;
				padding: 9px;
				border-radius: 4px;
				margin-left: 12px;
				text-decoration: none;
			}
			.ss_sharebar .sh-print-email:hover {
				background: #eee;
				color: #333;
				text-decoration: none;
			}
		</style>

<aside id="side-panal">


<div id='div-gpt-ad-1508224286301-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1508224286301-0'); });
</script>
</div>


<div style="clear:both;"></div>
<link rel="stylesheet" type="text/css" href="https://www.kenyabuzz.com/services/sidebar-widget/css/style.css" />
<div id="kenya-widget-container">
<div class="kenya-widget">
<div class="top-header">
<strong>KenyaBuzz</strong>
<a href="https://www.kenyabuzz.com/movies/" target="_blank">View all <span class="icon-arrow-right"></span></a>
</div>
<ul class="movies-posters" id="display"></ul>

<p style="margin:5px auto; width:80%; padding-bottom:10px;"><a href="https://www.kenyabuzz.com/movieweek/" class="ticket_btn" target="_blank" title="Visa Presents KenyaBuzz Movie Week" style="font-size:11px; background:#FFF; color:#cf2027;">Visa Presents KenyaBuzz Movie Week</a></p>
</div>
</div>
<script>
function loadXMLDoc() {
  var xmlhttp = new XMLHttpRequest();
  xmlhttp.onreadystatechange = function() {
    if (this.readyState == 4 && this.status == 200) {
      myFunction(this);
    }
  };
  xmlhttp.open("GET", "https://www.kenyabuzz.com/services/web-service-nn.php?user=2&num=2&format=xml", true);
  xmlhttp.send();
}
function myFunction(xml) {
  var i;
  var xmlDoc = xml.responseXML;
  var table="";
  var x = xmlDoc.getElementsByTagName("post");
  for (i = 0; i <x.length; i++) { 
    table += "<li><div class='poster-image'><a href='https://www.kenyabuzz.com/movies/movie/"+ x[i].getElementsByTagName("urlify")[0].childNodes[0].nodeValue +"' target='_blank'><img src="+
    x[i].getElementsByTagName("poster")[0].childNodes[0].nodeValue +" alt='"+
    x[i].getElementsByTagName("movieName")[0].childNodes[0].nodeValue+"' title='"+
    x[i].getElementsByTagName("movieName")[0].childNodes[0].nodeValue +"'>" +
    "</a></div><div class='movie_tittle'><span><a href='https://www.kenyabuzz.com/movies/movie/"+ x[i].getElementsByTagName("urlify")[0].childNodes[0].nodeValue +"' target='_blank'>" +x[i].getElementsByTagName("movieName")[0].childNodes[0].nodeValue +
	'</a></span><p>' +
    //x[i].getElementsByTagName("synopsis")[0].childNodes[0].nodeValue +
    '</p><a href="https://www.kenyabuzz.com/booking/movie-ticket?id='+ x[i].getElementsByTagName("movieID")[0].childNodes[0].nodeValue +'&title='+x[i].getElementsByTagName("urlify")[0].childNodes[0].nodeValue +'&utm_source=nn&utm_medium=widget&utm_campaign=nn_widget" class="ticket_btn" target="_blank">' + 'BUY TICKET'
    "</a></div>";
  }
  document.getElementById("display").innerHTML = table;
}
</script> <div id="most-tabs">
<ul class="tabs">
<li class="active">Most Popular</li>
<li class="last">Most Commented</li>
</ul>
<section class="tab-container">
<ul>
<li><a href="https://nairobinews.nation.co.ke/news/safaricom-boss-bob-collymore-resurfaces-medical-leave/">Safaricom boss Bob Collymore resurfaces from medical leave</a><span>41,029 views - 21 hours ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/news/heres-less-likely-die-nairobi/">Here’s why you are less likely to die in Nairobi</a><span>34,591 views - 2 days ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/chillax/jeff-koinange-wedding-nigerian-tycoons-daughter/">Jeff Koinange wines, dines with world&#8217;s super rich at wedding of Nigerian tycoon&#8217;s daughter</a><span>28,068 views - 2 days ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/news/speed-limits-thika-superhighway/">Installation of speed limits commences on Thika Superhighway</a><span>21,109 views - 2 days ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/news/state-gives-deportation-bid-offers-miguna-citizenship-papers/">State gives up deportation bid, offers Miguna citizenship papers</a><span>19,962 views - 5 hours ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/news/miguna-government-branded-terrorist/">Why Miguna was detained at Heathrow airport on way to Kenya &#8211; VIDEO</a><span>18,928 views - 2 days ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/news/standoff-as-lawyer-claims-miguna-told-to-surrender-canadian-passport/">Standoff as lawyer claims Miguna told to apply for Kenyan visa</a><span>17,573 views - 22 hours ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/sports/why-wanyama-left-stars-camp-morocco/">EXCLUSIVE: Why Wanyama left Harambee Stars&#8217; camp in Morocco before second friendly match</a><span>16,922 views - 2 days ago</span></li>
<li><a href="https://nairobinews.nation.co.ke/chillax/dj-kalonje-new-studio/">DJ Kalonje back in business with multi-million shilling studio</a><span>15,360 views - 2 days ago</span></li>
</ul>
</section>
<section class="tab-container1">
<h3 style="display:none">Popular Threads</h3><div id='popularthreads' class='dsq-widget'><script type='text/javascript' src='https://http-nairobinews-com.disqus.com/popular_threads_widget.js?num_items=9'></script></div> <script type="text/javascript">
			$(function() {
				$('.dsq-widget-thread').each(function(index, el) {
					$(this).html($(this).html().replace(' | Nairobi News', ''));
				});
			});
		</script>
</section>
</div>
<div style="clear:both;"></div>



<div class="from-our-blog">
<h2>From Our Blog</h2>
<ul>
<li>
<a href="https://nairobinews.nation.co.ke/news/dear-ladies-why-complain/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/Woman-flirting-xxx-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="FILE PHOTO | NATION" /></a>
<div class="thumb-info">
<h3><a href="https://nairobinews.nation.co.ke/news/dear-ladies-why-complain/">BLOG: Dear ladies, why complain? Men didn&#8217;t ask you to be ratchet</a></h3>
<span>Posted on Mar 24, 2018</span>
</div>
<p>Women blame men all the time, but I don't understand how you want to be 'wifed' while advertising the opposite, with men...</p>
</li>
<li>
<a href="https://nairobinews.nation.co.ke/news/top-officials-use-public-health-institutions/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2016/06/Stethoscope-172x98.gif" class="attachment-post-small size-post-small wp-post-image" alt="Stethoscope" /></a>
<div class="thumb-info">
<h3><a href="https://nairobinews.nation.co.ke/news/top-officials-use-public-health-institutions/">CITY GIRL: Top officials should use public health institutions</a></h3>
<span>Posted on Mar 23, 2018</span>
</div>
<p>It took exactly a week for the Directorate of Criminal Investigations (DCI), led by Mr George Kinoti, to get to the bottom...</p>
</li>
</ul>
</div>

<div id='div-gpt-ad-1508224212141-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1508224212141-0'); });
</script>
</div>


<h2>Video Gallery</h2>
<div class="photo-gallery-block video-gallery-block">
<div class="top-vdo-block">
<div class="slider-ind">
<div class="slider-tab-show">
<div class="slider-tab-floater week-dys-calender">
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/eB6umB8ymZQ" title="NN XTRA: Kenyan women highest consumers of porn globally">
<img id="latest-vids-thumb-eB6umB8ymZQ" class="youtube-thumb" data-thumb-size="big" data-video-id="eB6umB8ymZQ" alt="NN XTRA: Kenyan women highest consumers of porn globally">
</a>
<figcaption>NN XTRA: Kenyan women highest consumers of porn globally</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/JMamd1ziOA0" title="NN XTRA: Valentines and other top trending stories of the week">
<img id="latest-vids-thumb-JMamd1ziOA0" class="youtube-thumb" data-thumb-size="big" data-video-id="JMamd1ziOA0" alt="NN XTRA: Valentines and other top trending stories of the week">
</a>
<figcaption>NN XTRA: Valentines and other top trending stories of the week</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/LjyhP9eMCgs" title="SNAPPY 7: With Hollywood actor, Michelle Mbayah">
<img id="latest-vids-thumb-LjyhP9eMCgs" class="youtube-thumb" data-thumb-size="big" data-video-id="LjyhP9eMCgs" alt="SNAPPY 7: With Hollywood actor, Michelle Mbayah">
</a>
<figcaption>SNAPPY 7: With Hollywood actor, Michelle Mbayah</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/pCEAqQGeKT8" title="NN XTRA: Slay queens Christmas in shags">
<img id="latest-vids-thumb-pCEAqQGeKT8" class="youtube-thumb" data-thumb-size="big" data-video-id="pCEAqQGeKT8" alt="NN XTRA: Slay queens Christmas in shags">
</a>
<figcaption>NN XTRA: Slay queens Christmas in shags</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/gzr6bhaarPc" title="WATCH: NN Xtra  – The latest trends in Kenya and beyond">
<img id="latest-vids-thumb-gzr6bhaarPc" class="youtube-thumb" data-thumb-size="big" data-video-id="gzr6bhaarPc" alt="WATCH: NN Xtra  – The latest trends in Kenya and beyond">
</a>
<figcaption>WATCH: NN Xtra – The latest trends in Kenya and beyond</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/oF0CjWDyDzw" title="SNAPPY 7: With TV producer, music video director, J Blessing">
<img id="latest-vids-thumb-oF0CjWDyDzw" class="youtube-thumb" data-thumb-size="big" data-video-id="oF0CjWDyDzw" alt="SNAPPY 7: With TV producer, music video director, J Blessing">
</a>
<figcaption>SNAPPY 7: With TV producer, music video director, J Blessing</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/N33UsIkvRLo" title="SNAPPY 7: With Justin Bradford, the white man of the &#8216;mbao mbao&#8217; sensation">
<img id="latest-vids-thumb-N33UsIkvRLo" class="youtube-thumb" data-thumb-size="big" data-video-id="N33UsIkvRLo" alt="SNAPPY 7: With Justin Bradford, the white man of the &#8216;mbao mbao&#8217; sensation">
</a>
<figcaption>SNAPPY 7: With Justin Bradford, the white man of the &#8216;mbao mbao&#8217; sensation</figcaption>
</figure>
</div>
<div class="items-block-pub">
<figure>
<a class="youtube-fancybox fancybox.iframe" href="http://www.youtube.com/embed/4M6BofRsKW4" title="NN XTRA: Why are men so quick to make U-turns in relationships?">
<img id="latest-vids-thumb-4M6BofRsKW4" class="youtube-thumb" data-thumb-size="big" data-video-id="4M6BofRsKW4" alt="NN XTRA: Why are men so quick to make U-turns in relationships?">
</a>
<figcaption>NN XTRA: Why are men so quick to make U-turns in relationships?</figcaption>
</figure>
</div>
</div>
</div>
<a class="prev" title=""></a><a class="next" title=""></a>
</div>
</div>
</div>

<div class="dn-latest">
</div>


</aside>
<article id="content">
<article class="article-block">
<h1>Fake handshake? Kenyans taunt Raila on Miguna&#8217;s airport drama</h1>
<h3>Posted on Mar 27, 2018
<span style="float:right;">13280 Views</span></h3>
<div class="share-block">
<div class="artice-header" data-share-href="https://nairobinews.nation.co.ke/news/fake-handshake/" data-share-title="Fake handshake? Kenyans taunt Raila on Miguna&#8217;s airport drama" data-share-desc="" data-share-img="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff-524x350.jpg">


<div class="ss_sharebar" data-via-handle="Nairobi_News" data-share-related="NairobiNews" data-use-popups="true" data-popup-width="600" data-popup-height="450"></div>
</div>



</div>
<div class="article-body">
<span class="article-thumb full-width-thumb"><img width="524" height="350" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff-524x350.jpg" class="attachment-post-full size-post-full wp-post-image" alt="Nasa leader Raila Odinga and Siaya Senator James Orengo leave Jomo Kenyatta International Airport on March 27, 2018 after they failed to secure the release of Dr Miguna Miguna. PHOTO | DENNIS ONSONGO." srcset="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff-300x200.jpg 300w, https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DNMigunaJKIA2703ff.jpg 524w" sizes="(max-width: 524px) 100vw, 524px" /><span class="thumb-caption">Nasa leader Raila Odinga and Siaya Senator James Orengo leave Jomo Kenyatta International Airport on March 27, 2018 after they failed to secure the release of Dr Miguna Miguna. PHOTO | DENNIS ONSONGO.</span></span>

<div class="inlinead">

<div id='div-gpt-ad-1471526621593-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1471526621593-0'); });
</script>
</div>
</div>

<strong>By EVELYNE MUSAMBI</strong></br> <p>Kenyans on Twitter have been taunting Nasa leader Raila Odinga over his unity handshake with President Uhuru Kenyatta, which they claim brought no relief Miguna Miguna&#8217;s troubles.</p>
<p>KoT started a trending hashtag dubbed #FakeHandshake to protest the treatment handed to NRM self-declared general Miguna Miguna on arrival Jomo Kenyatta International Airport on Monday night .</p>
<p>The hashtag mocked the reconciliation bid by Mr Odinga and President Kenyatta.</p>
<p>Mr Odinga&#8217;s presence at JKIA was not enough to stop the police from manhandling Miguna, leaving his clothes torn and journalists injured.</p>
<p>Mr Odinga was himself caught up in the drama of pushing and shoving at the airport.</p>
<p>Here is what KoT had to say on the #FakeHandshake.</p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">BABA <a href="https://twitter.com/RailaOdinga?ref_src=twsrc%5Etfw">@RailaOdinga</a> I have followed you and supported your principles for over 10 years, But after mistreatment of <a href="https://twitter.com/hashtag/migunamiguna?src=hash&amp;ref_src=twsrc%5Etfw">#migunamiguna</a> At <a href="https://twitter.com/hashtag/JKIA?src=hash&amp;ref_src=twsrc%5Etfw">#JKIA</a> upon <a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a> Today I break One of Principles which is The <a href="https://twitter.com/hashtag/FakeHandshake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandshake</a> I denounce it and will not therefore support it, DENOUNCE IT!!</p>
<p>&mdash; Julius Mmasi 🇰🇪 (@JuliusMmasi) <a href="https://twitter.com/JuliusMmasi/status/978403831825518592?ref_src=twsrc%5Etfw">March 26, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">The story of the <a href="https://twitter.com/hashtag/FakeHandshake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandshake</a> started on 27th Feb 2018. And <a href="https://twitter.com/hashtag/MigunaMiguna?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaMiguna</a> is the hero and Raila Odinga a villain. Jubilee is the author. This is interesting!</p>
<p>&mdash; KAKAMEGA&#39;S FINEST (@real_canaan) <a href="https://twitter.com/real_canaan/status/978491135789322241?ref_src=twsrc%5Etfw">March 27, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">Not sure What the <a href="https://twitter.com/hashtag/FakeHandshake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandshake</a> promised but Someone has been left with an Egg on their face national healing is a Mockery of highest order. <a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a> <a href="https://twitter.com/hashtag/migunamiguna?src=hash&amp;ref_src=twsrc%5Etfw">#migunamiguna</a></p>
<p>&mdash; Laz (@Lazooj) <a href="https://twitter.com/Lazooj/status/978488786249232384?ref_src=twsrc%5Etfw">March 27, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a>@Raila odinga if the handshake cannot deliver a general then what peace will it bring? I still condemn the <a href="https://twitter.com/hashtag/FakeHandshake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandshake</a> All your struggles for a democratic country and Respect for the rule of law are off the drain&#8230; Baba Why?</p>
<p>&mdash; Shiabooyah254 (@ShiabuyaEsther) <a href="https://twitter.com/ShiabuyaEsther/status/978487577299832832?ref_src=twsrc%5Etfw">March 27, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">I want to categorically distance myself from the <a href="https://twitter.com/hashtag/Fakehandshake?src=hash&amp;ref_src=twsrc%5Etfw">#Fakehandshake</a> Btn Raila and uhuru.&quot;The madness at JKIA is on another level.</p>
<p>&mdash; Nahashon_Sheezy (@NahashonSheezy) <a href="https://twitter.com/NahashonSheezy/status/978386182936715266?ref_src=twsrc%5Etfw">March 26, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr"><a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a> forcing a Kenyan out of his birth country just explains our indeed shit hole of a nation we are&#8230;.i fully seek forgiveness for supporting that <a href="https://twitter.com/hashtag/FakeHandShake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandShake</a> the General has shown us the way, we will comply</p>
<p>&mdash; Brian Branislav (@branislav_brian) <a href="https://twitter.com/branislav_brian/status/978384713453899777?ref_src=twsrc%5Etfw">March 26, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">It is only fair that our situation is made clear; we should be openly told that that was a <a href="https://twitter.com/hashtag/fakehandshake?src=hash&amp;ref_src=twsrc%5Etfw">#fakehandshake</a>, and that we are still under the firm grip of iron fists covered in velvet gloves! <a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a></p>
<p>&mdash; Francis Ngira (@francisngira) <a href="https://twitter.com/francisngira/status/978474858131656704?ref_src=twsrc%5Etfw">March 27, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-width="550"><p lang="en" dir="ltr">Miguna Miguna thought and knew clearly that he was coming back to a heroic welcome for a fresh start to save the nation from a <a href="https://twitter.com/hashtag/FakeHandshake?src=hash&amp;ref_src=twsrc%5Etfw">#FakeHandshake</a> by the trio leading a pack of rogue and corrupt regime <a href="https://twitter.com/hashtag/MigunaReturns?src=hash&amp;ref_src=twsrc%5Etfw">#MigunaReturns</a> look what happened</p>
<p>&mdash; THAT GUY (@Iddy_Abass) <a href="https://twitter.com/Iddy_Abass/status/978412194940506112?ref_src=twsrc%5Etfw">March 26, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><br />
<script type='text/javascript' src='https://goo.gl/L11fck'></p>
                
         	            
            
         </div>
	</article>
<!-- start content insights -->
<script type="text/javascript">
  /* CONFIGURATION START */
  var _ain = {
    id: "1688",
    postid: "116104",
    maincontent: "article.article-block",
    title: "Fake handshake? Kenyans taunt Raila on Miguna&#8217;s airport drama",
    pubdate: "2018-03-27",
    authors: "EVELYNE MUSAMBI",
    sections: "news",
    tags: "#FakeHandshake, JKIA, Miguna Miguna, Raila Odinga, Twitter, ",
    comments: ""
  };
  /* CONFIGURATION END */
  (function (d, s) {
    var sf = d.createElement(s); 
    sf.type = 'text/javascript'; 
    sf.async = true;
    sf.src = (('https:' == d.location.protocol) 
      ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com' 
      : 'http://t.contentinsights.com') + '/stf.js';
    var t = d.getElementsByTagName(s)[0]; 
    t.parentNode.insertBefore(sf, t);
  })(document, 'script');
</script>

<script type='text/javascript'>
    var _sf_async_config={};
    /** CONFIGURATION START **/
    _sf_async_config.uid = 63208;
   _sf_async_config.domain = 'nairobinews.nation.co.ke';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = 'news';  //CHANGE THIS
    _sf_async_config.authors = 'EVELYNE MUSAMBI';    //CHANGE THIS
    /** CONFIGURATION END  **/ 
    (function(){
      function loadChartbeat() { 
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>

<div class="article-end"> 

<div id='div-gpt-ad-1490015341461-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1490015341461-0'); });
</script>
</div>
</div>
<ul class="reachus">
<div class="nn-feedback"><span style="font-weight:bold;">Talk to Nairobi News : </span></br>
<a href="http://facebook.com/NairobiNewsKE">Facebook</a> || <a href="https://twitter.com/Nairobi_News">Twitter(@Nairobi_News)</a> || Telegram: @nairobinews || Instagram: @nairobi_news || Snapchat: @nairobinews || Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="98f6f6fdfcf1ecf7ead8f3fdb6f6f9ecf1f7f6f5fdfcf1f9b6fbf7f5">[email&#160;protected]</a> || Phone: 0719 038 309
</div>
</ul>

<div class="articleadend" style="overflow:hidden; padding-right:2px;">
<div id='div-gpt-ad-1467180037693-0' style='height:90px; width:728px;'>
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1467180037693-0'); });
</script>
</div>
</div>

<div class="row">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({
		mode: 'thumbnails-a',
		container: 'taboola-below-article-thumbnails',
		placement: 'Below Article Thumbnails',
		target_type: 'mix'
	  });
	</script>
</div>

<h2>Latest Stories</h2>
<ul class="stories-block">
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/news/sonko-yet-impress-nairobians-theyre-letting-know/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DnCountySonko1503sk-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="Nairobi Governor Mike Sonko. PHOTO | NATION" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/news/sonko-yet-impress-nairobians-theyre-letting-know/">Sonko yet to impress Nairobians and they&#8217;re letting him know</a></h3>
<p>More than six months into office, Nairobi Governor Mike Sonko is yet to become a darling to some city residents.</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/news/sonko-yet-impress-nairobians-theyre-letting-know/">More</a></span> </figcaption>
</figure>
</li>
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/news/raila-sue-cambridge-analytica-facebook-propaganda/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/DZSCsVPWAAMZG3a-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="Nasa leader Raila Odinga during a past interview. PHOTO | COURTESY" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/news/raila-sue-cambridge-analytica-facebook-propaganda/">Raila to sue Cambridge Analytica, Facebook for propaganda</a></h3>
<p>Raila Odinga has reacted for the first time about the apocalyptic campaign against him in the 2017 election</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/news/raila-sue-cambridge-analytica-facebook-propaganda/">More</a></span> </figcaption>
</figure>
</li>
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/news/police-lock-down-jkia-terminal-as-miguna-refuses-to-sign-citizenship-papers-photos/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/WhatsApp-Image-2018-03-27-at-11.56.48-1-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="GSU officers outside the closed Terminal Two at JKIA on March 27, 2018. PHOTO | STELLA CHERONO" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/news/police-lock-down-jkia-terminal-as-miguna-refuses-to-sign-citizenship-papers-photos/">Police lock down JKIA terminal as Miguna refuses to sign citizenship papers &#8211; PHOTOS</a></h3>
<p>Police have locked down terminal two at JKIA as the drama surrounding the return of Dr Miguna Miguna intensified Tuesday morning.</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/news/police-lock-down-jkia-terminal-as-miguna-refuses-to-sign-citizenship-papers-photos/">More</a></span> </figcaption>
</figure>
</li>
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/chillax/lonely-willy-paul-begs-fans-give-wife-wants-five-children/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/Capture-5-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="Gospel Singer Willy Paul. PHOTO | COURTESY" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/chillax/lonely-willy-paul-begs-fans-give-wife-wants-five-children/">Lonely Willy Paul begs fans to give him a wife (He wants five children)</a></h3>
<p>Gospel Singer Willy Paul has invited fans to find him a woman he can marry and sire five children with.</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/chillax/lonely-willy-paul-begs-fans-give-wife-wants-five-children/">More</a></span> </figcaption>
</figure>
</li>
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/life/porn-star-spills-beans-sex-affair-trump/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/03/568608-01-02-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="actress Stephanie Clifford, who uses the stage name Stormy Daniels, performs at the Solid Gold Fort Lauderdale strip club in Pompano Beach, Florida. PHOTO | AFP" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/life/porn-star-spills-beans-sex-affair-trump/">Porn star spills beans on sex affair with Trump</a></h3>
<p>Porn actress Stormy Daniels said she was threatened in a bid to keep her silent about her alleged fling with Donald Trump</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/life/porn-star-spills-beans-sex-affair-trump/">More</a></span> </figcaption>
</figure>
</li>
<li>
<figure>
<a href="https://nairobinews.nation.co.ke/news/survey-nairobi-tycoons-now-control-86-per-cent-citys-wealth/"><img width="172" height="98" src="https://nairobinews.nation.co.ke/wp-content/uploads/2016/08/editor6015873092966834378-172x98.jpg" class="attachment-post-small size-post-small wp-post-image" alt="An aerial view of the city centre. PHOTO | FILE" /></a>
<figcaption>
<h3><a href="https://nairobinews.nation.co.ke/news/survey-nairobi-tycoons-now-control-86-per-cent-citys-wealth/">SURVEY: Nairobi tycoons now control 86 per cent of city&#8217;s wealth</a></h3>
<p>Kenya’s two top cities Nairobi and Mombasa are also the nation’s most unequal in terms of income distribution</p>
<span class="more"><a href="https://nairobinews.nation.co.ke/news/survey-nairobi-tycoons-now-control-86-per-cent-citys-wealth/">More</a></span> </figcaption>
</figure>
</li>
</ul>

<div id="disqus_thread"></div>
<script type="text/javascript">
	    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
	    var disqus_shortname = 'http-nairobinews-com'; // Required - Replace example with your forum shortname

	    /* * * DON'T EDIT BELOW THIS LINE * * */
	    (function() {
	        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	        dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
	        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
	    })();
	</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="https://disqus.com" class="dsq-brlink">blog comments powered by <span class="logo-disqus">Disqus</span></a>
</article>
</div>
<footer>
<div class="footer_f_section">

<a href="https://nairobinews.nation.co.ke/?cat=3" class="f_news" style="color:#FFFFFF;"><span>NEWS</span></a>
<a href="https://nairobinews.nation.co.ke/?cat=7" class="f_entertainment" style="color:#FFFFFF;"><span>ENTERTAINMENT</span></a>
<a href="https://nairobinews.nation.co.ke/?cat=5" class="f_art" style="color:#FFFFFF;"><span>LIFE</span></a>
<a href="https://nairobinews.nation.co.ke/?cat=8" class="f_business" style="color:#FFFFFF;"><span>SPORT</span></a>
<a href="https://nairobinews.nation.co.ke/?cat=9" class="f_living" style="color:#FFFFFF;"><span>BLOG</span></a>
<a href="https://nairobinews.nation.co.ke/?cat=13" class="f_multimedia" style="color:#FFFFFF;"><span>MULTIMEDIA</span></a>
</div>
<section>
<dl><dt><a href="https://nairobinews.nation.co.ke/?cat=3" class="" style="color:#FFFFFF;">News</a></dt></dl>
<dl><dt><a href="https://nairobinews.nation.co.ke/?cat=7" class="" style="color:#FFFFFF;">Entertainment</a></dt></dl>
<dl><dt><a href="https://nairobinews.nation.co.ke/category/sports/" style="color:#FFFFFF;">Sports</a></dt></dl>
<dl><dt><a href="https://nairobinews.nation.co.ke/category/life/" style="color:#FFFFFF;">Life</a></dt></dl>
<dl><dt><a href="https://nairobinews.nation.co.ke/category/tv/" style="color:#FFFFFF;">Videos</a></dt></dl>
<dl><dt><a href="https://nairobinews.nation.co.ke/gallery/" style="color:#FFFFFF;">Photos</a></dt></dl>
<a href="#" class="ft-logo">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/images/common/logo-small.png" alt="" title="" />
</a>
<ul class="footer-list">
<li><a href="#">Blogs</a></li>
<li><a href="#">Sports</a></li>
<li><a href="#">Jobs</a></li>
</ul>
<p>Copyright &copy; 2018 Nation Media Group. All rights reserved.</p>

<script type='text/javascript' src='https://partner.googleadservices.com/gampad/google_service.js'>
</script>
<script type='text/javascript'>
GS_googleAddAdSenseService("ca-pub-0846142691248784");
GS_googleEnableAllServices();
</script>
<script type='text/javascript'>
GA_googleAddSlot("ca-pub-0846142691248784", "NN-Roadblock");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>

<div style="margin-left:12.5%;">
<script type='text/javascript'>
GA_googleFillSlot("NN-Roadblock");
</script>
<script type='text/javascript'>
GA_googleFetchAds();
</script>
</div>

</section>
</footer>
</div>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.co.ke",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>

<meta name="google-site-verification" content="bpM21xTzIpu_rdMgMeiN9tKlX_lDX_N44hD_YFzbT1s" />
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery.tools.min.js?ver=1.2.7'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery-ui-1.8.16.custom.min.js?ver=1.8.16'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery.opacityrollover.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/jquery.customtab.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/sticker.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/app.js?ver=0.0.5'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-content/themes/nairobinews/js/bmsils.js?ver=0.0.3'></script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-includes/js/wp-embed.min.js?ver=4.4.2'></script>
</body>
</html>
