<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="ie=edge">
<meta name="theme-color" content="#F0F0F0">
<meta name="msapplication-TileColor" content=#F0F0F0>
<meta property="og:locale" content="en_GB">
<meta property="og:locale:alternate" content="en_US">
<meta property="og:type" content="website" />
<meta name="robots" content="index,follow">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<meta name="copyright" content="Nation Media Group">
<link rel="manifest" href="https://nairobinews.nation.co.ke/manifest.json">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="mobile-web-app-capable" content="yes">
<link rel="canonical" href="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" />
<link rel="amphtml" href="https://nairobinews.nation.co.ke/amp/editors-picks/babu-owino-shares-his-softer-side-leaves-fans-swooning">
<link rel="shortcut icon" type="image/x-icon" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon.ico">
<link rel="icon" type="image/png" sizes="32x32" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-64x64.png">
<link rel="icon" type="image/png" sizes="24x24" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-24x24.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/favicon/favicon-16x16.png">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="stylesheet" href="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/css/main_v2.css?v=2">
<title>Babu Owino shares his softer side, leaves fans swooning &#8211; Nairobi News</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Feed" href="https://nairobinews.nation.co.ke/feed" />
<link rel="alternate" type="application/rss+xml" title="Nairobi News &raquo; Comments Feed" href="https://nairobinews.nation.co.ke/comments/feed" />
<meta property="og:title" content="Babu Owino shares his softer side, leaves fans swooning" />
<meta property="og:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" />
<meta property="og:site_name" content="Nairobi News" />
<meta property="og:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f.jpg" />
<meta name="keywords" content="babu owino,Embakasi East," />
<meta property="fb:app_id" content="119242211439858" />
<meta property="fb:pages" content="497615353664351" />
<meta property="og:locale" content="en_UK" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:article:published_time" content="2019-05-31 14:00:47" />

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Nairobi_News" />
<meta name="twitter:title" content="Babu Owino shares his softer side, leaves fans swooning" />
<meta name="twitter:description" content="News,Gossip,Sports and Entertainment from Nairobi." />
<meta name="twitter:image" content="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f.jpg" />
<meta name="twitter:url" content="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nairobinews.nation.co.ke\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='_nn_clean-style-css' href='https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/style.css' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://nairobinews.nation.co.ke/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nairobinews.nation.co.ke/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nairobinews.nation.co.ke/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.9" />
<link rel="canonical" href="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" />
<link rel='shortlink' href='https://nairobinews.nation.co.ke/?p=149960' />
<link rel="alternate" type="application/json+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Ffeatured%2Fbabu-owino-shares-his-softer-side-leaves-fans-swooning" />
<link rel="alternate" type="text/xml+oembed" href="https://nairobinews.nation.co.ke/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnairobinews.nation.co.ke%2Ffeatured%2Fbabu-owino-shares-his-softer-side-leaves-fans-swooning&#038;format=xml" />


<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1030601-4"></script>
<script>
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'UA-1030601-4');
    </script>


<script type="text/javascript">
        _atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.co.ke",dynamic: true};
        (function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
    </script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
            googletag.cmd.push(function() {
                googletag.defineOutOfPageSlot('/1010816/NN-Out-of-Page', 'div-gpt-ad-1540468650627-0').addService(googletag.pubads());
                googletag.enableServices();
            });
        </script>
<script type="text/javascript">
            window._taboola = window._taboola || [];
            _taboola.push({article:'auto'});
            !function (e, f, u, i) {
                if (!document.getElementById(i)){
                    e.async = 1;
                    e.src = u;
                    e.id = i;
                    f.parentNode.insertBefore(e, f);
                }
            }(document.createElement('script'),
                document.getElementsByTagName('script')[0],
                '//cdn.taboola.com/libtrc/nmg-nairobinews/loader.js',
                'tb_loader_script');
        </script>
<script type="text/javascript">
        var _sf_async_config = _sf_async_config || {};
        /** CONFIGURATION START **/
        _sf_async_config.uid = 63208; // ACCOUNT NUMBER
        _sf_async_config.domain = 'nairobinews.nation.co.ke'; // DOMAIN
        _sf_async_config.flickerControl = false;
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = false;
        /** CONFIGURATION END **/
        var _sf_startpt = (new Date()).getTime();
    </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<meta name="google-site-verification" content="Yo5tTKQh8_E8Z1u-si3gaQLwezTdZ4A_r-IKKuTQgqA" />
</head>
<body class="inner-body">
<div id="content_overlay"></div>
<div id="mp-menu" class="mp-menu">
<div class="mp-level">
<div class="mp-level-scroll">
<div class="search-form">
<div class="form-container posRelative">

<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
<ul id="menu-primary" class="unstyled"><li id="menu-item-142041" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li id="menu-item-137017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li id="menu-item-136581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li id="menu-item-136580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li id="menu-item-136578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li id="menu-item-136577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li id="menu-item-136582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li id="menu-item-136579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> <div class="whats-appLink">
<div class="title">Join our WhatsApp Channel</div>
<a href="javascript:void(0);">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp</span>
</a>
</div>
<div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<span class="title">Connect with us</span>
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>

</ul>
</div>
</div>
</div>
</div>
</div>
<div id="top-section">
<header id="main-header" class="clearfix">
<div class="row">
<div class="row">
<div class="grid-2 cell">
<div class="site-branding">
<h1 style="font-size: 0px; margin: 0px;">Nairobi News</h1>
<div class="site-logo mobile-hidden">
<a href="https://nairobinews.nation.co.ke/?"><img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo.svg" alt="Nairobi News Logo" /></a>
</div>
</div>
</div>
<div class="grid-10 cell">
<div class="ad-container nobg">
<div id="custom_html-26" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
var mapping = googletag.sizeMapping().addSize([1024, 0], [[970, 90], [728, 90]]).addSize([600, 0], [300, 250]).addSize([800, 0], [728, 90]).addSize([0, 0], [300, 250]).build();   
googletag.defineSlot('/1010816/NN-ARTICLE-1', [[970,90],[300, 250], [728, 90]], 'div-gpt-ad-1553665820582-0').defineSizeMapping(mapping).addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665820582-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665820582-0'); });
</script>
</div></div></div> </div>
</div>
</div>
</div>
<div id="mobile-menu" class="mobile-menu web-hidden">
<div class="row">
<div class="row">
<div class="grid-6 cell">
<div class="site-logo">
<a href="https://nairobinews.nation.co.ke">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-black.svg" alt="Nairobi News Logo" />
</a>
</div>
</div>
<div class="grid-6 cell">
<div id="js-mobile-menu" class="hamburger-menu menu-on mobile-menuclose">
<div class="line-menu"></div>
<div class="line-menu"></div>
<div class="line-menu"></div>
</div>
</div>
</div>
</div>
</div>
</header>
<nav id="main-navigation" class="main-nav clearfix" role="nav">
<div class="content">
<div class="row">
<div class="nav-left">
<ul id="menu-primary-1" class="unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142041"><a href="https://nairobinews.nation.co.ke/?">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-137017"><a href="https://nairobinews.nation.co.ke/top-news">Top News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136581"><a href="https://nairobinews.nation.co.ke/chillax">Chillax</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136580"><a href="https://nairobinews.nation.co.ke/life">Life</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136578"><a href="https://nairobinews.nation.co.ke/hustle">Hustle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136577"><a href="https://nairobinews.nation.co.ke/sports">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136582"><a href="https://nairobinews.nation.co.ke/blog">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-136579"><a href="https://nairobinews.nation.co.ke/gallery">Gallery</a></li>
</ul> </div>
<div class="nav-right">
<div id="search-show" class="right-search">
<div class="right-search__icon search-close">
<span class="fa fa-search"></span>
</div>
<div class="search-form">
<div class="form-container">
<form action="https://nairobinews.nation.co.ke/results" method="get">
<input type="text" name="q" value="" class="input-text" placeholder="Type here to search..." />
<button type="submit" class="search-submit"></button>
</form>
</div>
</div>
</div>
 <div class="meta-social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a href="https://www.facebook.com/NairobiNewsKE/" target="_blank" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a href="https://twitter.com/Nairobi_News" target="_blank" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="instagram">
<a href="https://instagram.com/Nairobi_News" target="_blank" title="Instagram">
<i class="fa fa-instagram"></i>
<span class="hide">Instagram</span>
</a>
</li>
<li id="alerts" class="alert close">
<a href="javascript:void(0);" title="Updates made in the last 20 minutes">
<span class="alert-num">
0 </span>
<i class="fa fa-bell"></i>
<span class="hide">Alerts</span>
</a>
</li>
</ul>
</div>
</div>
<div id="dropdown-latest" class="dropdown-item">
<div class="dropdown-content">

</div>
</div>
</div>
</div>
</div>
</nav>
</div>
<main id="main-content" role="content"> <main id="main-content" role="content">
<section id="single-content" class="single-content mt-40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-8 cell">
<div class="single-container">
<div class="article-content">
<div class="article-content__top">
<div class="content-top__title">
<span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/editors-picks">Must Read</a></span><span class="meta-label"><a href="https://nairobinews.nation.co.ke/category/featured">What's Hot</a></span> <h2>Babu Owino shares his softer side, leaves fans swooning</h2>
</div>
<div class="content-top__meta mt-20 clearfix">
<div class="row">
<div class="grid-6 cell">
<div class="meta-articles__details">
<div class="meta-avatar">
<div class="avatar-content">
<div class="avatar-content__img wp-post-image" data-bg="url()"></div>
</div>
</div>
<div class="meta-details">
<div class="meta-author">
<span class="render-text by">
<span class="mr-5">By</span>
<a href="javascript:void(0);" role="author">
Sylvania Ambani</a></span>
<span>May 31st, 2019 <i class="dot"></i> 1 min read</span>
</div>
</div>
</div>
</div>
<div class="grid-6 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li>
<span>Share this</span>
</li>
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;t=Babu Owino shares his softer side, leaves fans swooning" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;t=Babu Owino shares his softer side, leaves fans swooning" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;text=Babu Owino shares his softer side, leaves fans swooning" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&title=Babu Owino shares his softer side, leaves fans swooning&summary=Babu Owino shares his softer side, leaves fans swooning&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#92ade1e7f0f8f7f1e6afd0f3f0e7b2dde5fbfcfdb2e1faf3e0f7e1b2fafbe1b2e1fdf4e6f7e0b2e1fbf6f7beb2fef7f3e4f7e1b2f4f3fce1b2e1e5fdfdfcfbfcf5b4f0fdf6ebaffae6e6e2e1a8bdbdfcf3fbe0fdf0fbfcf7e5e1bcfcf3e6fbfdfcbcf1fdbcf9f7bdf4f7f3e6e7e0f7f6bdf0f3f0e7bffde5fbfcfdbfe1faf3e0f7e1bffafbe1bfe1fdf4e6f7e0bfe1fbf6f7bffef7f3e4f7e1bff4f3fce1bfe1e5fdfdfcfbfcf5" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
</a>
</li>
<li class="email" style="display: none;">
<a href="javascript:void(0);" id="#work" title="Share this via PWA" style="display: none;">
<i class="fa fa-share-alt"></i>
<span class="hide">Share this via PWA</span>
</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="article-content__banner">
<div class="banner-container">
<div class="banner-image">
<img width="1320" height="742" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f-150x150.jpg" class="attachment-single-image size-single-image wp-post-image" alt="DNBABUWINS0806f" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f.jpg" title="DNBABUWINS0806f" /> </div>
<div class="banner-caption">

<span class="render-text">Embakasi East MP Babu Owino with supporters outside the Supreme Court on June 8, 2018. PHOTO | FRANCIS NDERITU</span> </div>
</div>
</div>
<div class="article-content__content clearfix mt-40">
<div class="incontent-ad" style="float:left; width:300px; padding:0px;margin:5px;">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
											googletag.cmd.push(function() {
											googletag.defineSlot('/1010816/NN-ARTICLE-4', [300, 250], 'div-gpt-ad-1553666013837-0').addService(googletag.pubads());
											googletag.enableServices(); });
											</script>
<div id='div-gpt-ad-1553666013837-0' style='height:250px; width:300px;'>
<script>
											googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553666013837-0'); });
											</script>
</div>
<br />
</div>
<p>Embakasi East Member of Parliament Babu Owino has often been described as a man with a penchant for courting trouble, but a recent post on his Instagram page has painted him to his fans in a different light.</p>
<p>Babu shared a never-seen-before picture while adorably holding his two cute daughters which has painted him as a doting father away from the abrasive side many Kenyans know him for especially in the political arena.</p><div class="other-stories related-content clearfix"><div class="grid-12 cell"><h3>OTHER ARTICLES</h3></div><div class="row"><ul><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/editors-picks/kq-explains-why-you-cant-change-seats-freely-in-half-empty-flights><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/10/WhatsApp-Image-2018-10-29-at-14.38.06-1saw.jpg" /></span><span class="related-content__text">KQ explains why you can’t change seats freely in half-empty flights</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/editors-picks/sonko-redoes-the-nyayo-roundabout-despite-unaccounted-expenditure><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DvVfzJlXgAArFBc-150x150.jpg" /></span><span class="related-content__text">Sonko redoes the Nyayo roundabout despite unaccounted expenditure</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/blog/the-millennial-why-ill-soon-drop-my-english-name><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Stressedman0505-150x150.jpg" /></span><span class="related-content__text">THE MILLENNIAL: Why I’ll soon drop my English name</span></a></li></div><div class="grid-6 cell"><li><a href=https://nairobinews.nation.co.ke/editors-picks/somali-woman-rescued-from-eastleigh-brothel-where-husband-dumped-her><span class="related-content__image"><img src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/05/DNEastleigh0405w.jpg" /></span><span class="related-content__text">Somali woman rescued from Eastleigh brothel where &#8216;husband&#8217; dumped her</span></a></li></div></ul></div></div>
<p>Fans were left swooning over the photo of the legislator and his two beautiful daughters who adorably posed.</p>
<p>Kenyans online were amazed at this mellow side of the fiery and outspoken politician who has always managed to keep his family away from the limelight.</p>
<p>“Fatherhood is the best thing that can happen to a man. A life changing phase in a man’s span. It affirms fruitfulness and selflessness CONGRATULATIONS MHESHIMIWA,” said blakaende.</p>
<p>“Girls are the best! They are so cute congrats,” wrote anurozaf.</p>
<p>“Oohhh wow they look soo sweet,” commented nesh.</p>
<p>“Cute babies honourable Congrats,” stated antonineakiny.</p><div class='mobile-ad' style='padding:5px;'>

<div id='div-gpt-ad-1547187122892-0'>
<script>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1547187122892-0'); });
				</script>
</div>
</div>
<p>“Ooooh babu Owino has a softer side,” replied daisytherealdeal.</p>
<p>“They are so beautiful looking like dad. Congratulations,” said faithakinyi.</p>
<p>Babu Owino is married to his long term girlfriend Fridah Owino, who he met at the University of Nairobi seven years ago.</p>
<p>They were both then first year students, he was pursuing a degree in Actuarial Science as she pursued a Bachelor&#8217;s degree in Economics.</p>
<p>After three years of dating, he finally made their relationship official in a small ceremony that included family members and close friends.</p>
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/ByHMNKfnop8/" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:640px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;"> <a href="https://www.instagram.com/p/ByHMNKfnop8/" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> </p>
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<p></a> </p>
<p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/ByHMNKfnop8/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Me,myself and I.#DisturbingPeace</a></p>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/he.babuowino/" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Hon.Babu Owino</a> (@he.babuowino) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-05-31T03:47:17+00:00">May 30, 2019 at 8:47pm PDT</time></p>
</div>
</blockquote>
<p><script async src="//www.instagram.com/embed.js"></script></p>
<p>&nbsp;</p>
</div>
<div class="article-content__tags">
<div class="list-tags">
<ul class="unstyled"><li><a href="https://nairobinews.nation.co.ke/tag/babu-owino" rel="tag">babu owino</a></li><li><a href="https://nairobinews.nation.co.ke/tag/embakasi-east" rel="tag">Embakasi East</a></li></ul>
</div>
<div class="join-wc clearfix">
<div class="row">
<div class="grid-8 cell">
<div class="join-text">
<p>Nairobi News is now available on WhatsApp. For handpicked stories every day, subscribe to our</p>
</div>
</div>
<div class="grid-4 cell">
<div class="join-link whats-appLink">
<a href="https://wb.messengerpeople.com/?widget_hash=0cda75ec47718042f9c019db68d3f6e4&lang=en&wn=0" target="_blank">
<i class="fa fa-whatsapp"></i>
<span>WhatsApp channel</span>
</a>
</div>
</div>
</div>
</div>
</div>
<div id="stick-article-nav" class="article-content___nav">
<div class="row">
<div class="grid-4 cell">
<div class="content-nav__item prev-item">
<a href="https://nairobinews.nation.co.ke/editors-picks/kq-explains-why-you-cant-change-seats-freely-in-half-empty-flights" title="KQ explains why you can’t change seats freely in half-empty flights">
<span class="hide-mobile">
KQ explains why you can’t change seats freely in... </span>
</a>
</div>
</div>
<div class="grid-4 cell">
<div class="meta-articles__social clearfix">
<div class="social-content">
<ul class="unstyled">
<li class="facebook">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;t=Babu Owino shares his softer side, leaves fans swooning" target="_blank" data-url="http://www.facebook.com/sharer/sharer.php?u=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;t=Babu Owino shares his softer side, leaves fans swooning" title="Facebook">
<i class="fa fa-facebook"></i>
<span class="hide">Facebook</span>
</a>
</li>
<li class="twitter">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://twitter.com/intent/tweet?url=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&amp;text=Babu Owino shares his softer side, leaves fans swooning" title="Twitter">
<i class="fa fa-twitter"></i>
<span class="hide">Twitter</span>
</a>
</li>
<li class="linkedin">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="https://www.linkedin.com/shareArticle?mini=true&url=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning&title=Babu Owino shares his softer side, leaves fans swooning&summary=Babu Owino shares his softer side, leaves fans swooning&source=NairobiNews" title="LinkedIn">
<i class="fa fa-linkedin"></i>
<span class="hide">LinkedIn</span>
</a>
</li>
<li class="email">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="/cdn-cgi/l/email-protection#a798d4d2c5cdc2c4d39ae5c6c5d287e8d0cec9c887d4cfc6d5c2d487cfced487d4c8c1d3c2d587d4cec3c28b87cbc2c6d1c2d487c1c6c9d487d4d0c8c8c9cec9c081c5c8c3de9acfd3d3d7d49d8888c9c6ced5c8c5cec9c2d0d489c9c6d3cec8c989c4c889ccc288c1c2c6d3d2d5c2c388c5c6c5d28ac8d0cec9c88ad4cfc6d5c2d48acfced48ad4c8c1d3c2d58ad4cec3c28acbc2c6d1c2d48ac1c6c9d48ad4d0c8c8c9cec9c0" title="Email" target="_blank">
<i class="fa fa-envelope-o"></i>
<span class="hide">Email</span>
</a>
</li>
<li class="whatsapp">
<a OnClick="window.open(this.href,'targetWindow','toolbar=no,location=0,status=no,menubar=no,scrollbars=yes,resizable=yes,width=600,height=250'); return false;" href="whatsapp://send?text=https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning" title="WhatsApp">
<i class="fa fa-whatsapp"></i>
<span class="hide">WhatsApp</span>
 </a>
</li>
</ul>
</div>
</div>
</div>
<div class="grid-4 cell">
</div>
</div>
</div>
</div>
<div class="articles-content__author mt-40">
<div class="about-title">
<div class="about-title__content">
<h2>About the author</h2>
</div>
</div>
<div class="author-content clearfix mt-20">

<div class="author-details">
<h3>Sylvania Ambani</h3>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='//www.youtube.com/iframe_api'></script>
<script type='text/javascript'>
                                        _sf_async_config.path = "https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning";
                                        _sf_async_config.sections = "Must Read,What's Hot,";
                                        _sf_async_config.authors = "Sylvania Ambani";								
                                        _sf_async_config.autoDetect=false;
                                        /** CONFIGURATION END **/
                                        (function(){
                                            function loadChartbeat() {
                                                var e = document.createElement('script');
                                                var n = document.getElementsByTagName('script')[0];
                                                e.type = 'text/javascript';
                                                e.async = true;
                                                e.src = '//static.chartbeat.com/js/chartbeat_video.js';
                                                n.parentNode.insertBefore(e, n);
                                            }
                                            var _cbv = window._cbv || (window._cbv = []);_cbv.push(['autoDetectYouTubeIframes']);
                                            loadChartbeat();
                                        })();
                                    </script>


<script type="text/javascript">
                                        /* CONFIGURATION START */
                                        var _ain = {
                                            id: "1688",
                                            postid: "149960",
                                            maincontent: ".content-top__title, .article-content__content",
                                            excludecontent: "#taboola-below-article-thumbnails",
                                            title: "Babu Owino shares his softer side, leaves fans swooning",
                                            pubdate: "2019-05-31",
											authors: "Sylvania Ambani",								
											sections: "Must Read,What's Hot,",
                                            tags: "babu owino, Embakasi East, ",
                                            comments: ""
                                        };
                                        /* CONFIGURATION END */
                                        (function (d, s) {
                                            var sf = d.createElement(s);
                                            sf.type = 'text/javascript';
                                            sf.async = true;
                                            sf.src = (('https:' == d.location.protocol)
                                                ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com'
                                                : 'http://t.contentinsights.com') + '/stf.js';
                                            var t = d.getElementsByTagName(s)[0];
                                            t.parentNode.insertBefore(sf, t);
                                        })(document, 'script');
                                    </script>

<br />
<div id="custom_html-22" class="widget_text add-list widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-0846142691248784" data-ad-slot="4659675794" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> </div>
<div class="articles-content__related mt-40">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Also read</a>
</h2>
</div>
</div>
</div>
<div id="trending-pane" class="posRelative mobile-full">
<div class="row">
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/life/police-open-investigation-after-kenyan-woman-found-dead-in-australia">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Jelagat-Cheruiyot-150x150.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="Jelagat Cheruiyot" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Jelagat-Cheruiyot-470x264.jpg" title="Jelagat Cheruiyot" />  </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Police open investigation after Kenyan woman is found dead in Australia</h3>
</div>
<div class="content-meta">
<span class="render-text">May 30th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/life/woman-handed-life-in-jail-for-killing-uon-student-over-affair-with-husband">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/kihiu-pic-copy-150x150.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="kihiu-pic-copy" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/kihiu-pic-copy-470x264.jpg" title="kihiu-pic-copy" /> </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Woman handed life in jail for killing UoN student over &#8216;affair with husband&#8217;</h3>
</div>
<div class="content-meta">
<span class="render-text">May 30th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="item grid-4 cell">
<div class="item-content">
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/sports/rachier-mugabe-museveni-chants-have-chased-me-from-gor">
<div class="pane-box__img">
<img width="470" height="264" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DnsportsNyasa2611bb-150x150.jpg" class="attachment-regular-thumb size-regular-thumb wp-post-image" alt="DnsportsNyasa2611bb" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DnsportsNyasa2611bb-470x264.jpg" title="DnsportsNyasa2611bb" /> </div>
<div class="pane-box__content">
<div class="content-title">
<h3>Rachier: &#8216;Mugabe&#8217; &#8216;Museveni&#8217; chants have chased me from Gor</h3>
</div>
<div class="content-meta">
<span class="render-text">May 27th, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div id="taboola-ads" class="taboola-ad-below-article">

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                                        window._taboola = window._taboola || [];
                                        _taboola.push({
                                            mode: 'thumbnails-a',
                                            container: 'taboola-below-article-thumbnails',
                                            placement: 'Below Article Thumbnails',
                                            target_type: 'mix'
                                        });
                                    </script>

</div>
</div>
</div>
<div class="grid-4 cell">
<div class="ad-container">
<div id="custom_html-6" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-2', [300, 250], 'div-gpt-ad-1553665892910-0').addService(googletag.pubads());
googletag.enableServices();});
</script>
<div id='div-gpt-ad-1553665892910-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665892910-0'); });
</script>
</div></div></div> 
</div>
<div id="mustr-pane" class="vidoes-pane mt-20">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://nairobinews.nation.co.ke/top-news/">Latest Stories<i class="fa fa-angle-right"></i></a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/kq-explains-why-you-cant-change-seats-freely-in-half-empty-flights">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2018/10/WhatsApp-Image-2018-10-29-at-14.38.06-1saw.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>KQ explains why you can’t change seats freely in...</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/sonko-redoes-the-nyayo-roundabout-despite-unaccounted-expenditure">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DvVfzJlXgAArFBc-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Sonko redoes the Nyayo roundabout despite unaccounted...</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/blog/the-millennial-why-ill-soon-drop-my-english-name">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Stressedman0505-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>THE MILLENNIAL: Why I’ll soon drop my English name</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/somali-woman-rescued-from-eastleigh-brothel-where-husband-dumped-her">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2018/05/DNEastleigh0405w.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Somali woman rescued from Eastleigh brothel where...</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/news/kenyan-al-shabaab-fighter-surrenders-days-before-staging-attacks">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Al-Shabaab-180x180.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Kenyan Al-Shabaab fighter surrenders days before staging...</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/editors-picks/kenyans-livid-after-pastor-nganga-calls-his-bishops-labish-takataka">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Pastor-Nganga-180x180.jpg)"></div>
</div>
 <div class="pane-box__content">
<div class="content-title">
<h3>Kenyans livid after Pastor Ng’ang’a calls his bishops...</h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</a>
</div>
</div>
</div>
<div class="ad-container">
<div id="custom_html-7" class="widget_text add-list widget_custom_html"><div class="textwidget custom-html-widget"><script>
googletag.cmd.push(function() {
googletag.defineSlot('/1010816/NN-ARTICLE-3', [300, 250], 'div-gpt-ad-1553665956712-0').addService(googletag.pubads());
googletag.enableServices(); });
</script>
<div id='div-gpt-ad-1553665956712-0' style='height:250px; width:300px;margin:0px auto;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1553665956712-0'); });
</script>
</div></div></div> </div>
<div id="vidoes-pane" class="vidoes-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<div class="pane-title-label">
<a href="https://nairobinews.nation.co.ke/gallery/">Watch<i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img posRelative">
<a data-fancybox="" href="https://www.youtube.com/embed/YRsuAUq-GcQ?rel=0?autoplay=0" target="_blank">
<div class="play-video__btn" onclick="updateURL('videos/if-you-cannot-tame-ruto-hand-him-over-to-me-atwoli-to-uhuru');">
<div class="centered">
<div class="centeredInner">
<i class="fa fa-play"></i>
</div>
</div>
</div>
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Atwoli-180x180.jpg)"></div>
</a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/videos/if-you-cannot-tame-ruto-hand-him-over-to-me-atwoli-to-uhuru">&#8220;If you cannot tame Ruto, hand him over to me&#8221;...</a></h3>
</div>
<div class="content-meta">

</div>
 </div>
</div>
<div class="pane-box">
<div class="pane-box__img posRelative">
<a data-fancybox="" href="https://www.youtube.com/embed/9WvViWK7e60?rel=0?autoplay=0" target="_blank">
<div class="play-video__btn" onclick="updateURL('videos/kagwe-mungai-launches-studio-album-titled-spectrum');">
<div class="centered">
<div class="centeredInner">
<i class="fa fa-play"></i>
</div>
</div>
</div>
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Kagwe-3-180x180.jpg)"></div>
</a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/videos/kagwe-mungai-launches-studio-album-titled-spectrum">Kagwe Mungai launches studio album titled ‘Spectrum’</a></h3>
</div>
<div class="content-meta">

</div>
</div>
</div>
</div>
</div>
<div id="gallery-pane" class="gallery-pane mt-20">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<div class="pane-title-label">
<a href="https://nairobinews.nation.co.ke/gallery/">Photo Gallery<i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/sunny-reggae">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/NN-Reggae-Sun-b-1-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">6</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Sunny Reggae</h3>
</div>
<div class="content-meta">
 
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/faso-show">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/NN-Faso-e-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">6</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Faso Show</h3>
</div>
<div class="content-meta">

</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://nairobinews.nation.co.ke/photos/nmg-60">
<div class="pane-box__img posRelative">
<div class="img-boxbg wp-post-image" data-bg="url(https://nairobinews.nation.co.ke/wp-content/uploads/2019/04/NMG-@60-2-1-550x520.jpg)"></div>
<div class="pic-num">
<div class="pic-icon">
<i class="fa fa-camera"></i>
</div>
<div class="count">8</div>
</div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>NMG @ 60</h3>
</div>
<div class="content-meta">

</div>
</div>
</a>
</div>
</div>
</div>
<div id="buzz-pane" class="buzz-pane">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="https://www.kenyabuzz.com/" target="_blank">KenyaBuzz<i class="fa fa-angle-right"></i></a>
</h2>
 </div>
</div>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/long-shot" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://image.tmdb.org/t/p/w342//m2ttWZ8rMRwIMT7zA48Jo6mTkDS.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Long Shot</h3>
</div>
<div class="content-capt">
<p>When Fred Flarsky reunites with his first crush, one of the... </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/movies/movie/godzilla-king-of-the-monsters" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://image.tmdb.org/t/p/w342//pU3bnutJU91u3b4IeRPQTOP8jhV.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Godzilla: King of the Monsters</h3>
</div>
<div class="content-capt">
<p> </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/events/event/celtic-dream-dance" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://www.kenyabuzz.com/public/uploads/events/862952408e137af1439412805a3c3226.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Celtic Dream Dance</h3>
</div>
<div class="content-capt">
<p>The Celtic Dream is a dance show demonstrating a mixture of... </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
<div class="pane-box">
<a href="https://www.kenyabuzz.com/events/event/convos-with-kesh" target="_blank">
<div class="pane-box__img posRelative">
<div class="pane-bg" style="background-image: url(https://www.kenyabuzz.com/public/uploads/events/344c26cfef52a9e1c5dc2c4aa070c044.jpg)"></div>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3>Convos with Kesh</h3>
</div>
<div class="content-capt">
<p>ConvoswithKesh is a themed interactive monthly relationship... </p>
</div>
<div class="content-meta">
<span class="render-text">BUY TICKET</span>
</div>
</div>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</section>
</main>
<footer id="main-footer" class="mt-40" role="footer">
<div class="top-footer padt40 padb40 clearfix">
<div class="content">
<div class="row">
<div class="row">
<div class="grid-4 cell">
<div class="top-footer__about">
<div class="about-logo__img">
<img src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/images/logo-footer.png" alt="Nairobi News Logo" />
</div>
<div id="custom_html-20" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">Nairobi News is the most trusted website in Kenya that provides the latest breaking news, entertainment news, sports news, showbiz and celebrity stories.
will also keep you hooked with memes, gifs and funny videos.</div></span></div><div id="custom_html-21" class="widget_text about-img__text add-list widget widget_custom_html"><span class="widget_text render-text"><div class="textwidget custom-html-widget">
<div id='div-gpt-ad-1540468650627-0'>
<script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540468650627-0'); });
        </script>
</div> </div></span></div>

</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
 <div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Most Popular</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/life/waititu-weds-wife-in-traditional-ceremony-as-graft-probe-haunts-family"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Waititu-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Waititu" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Waititu-470x264.jpg" title="Waititu" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/life/waititu-weds-wife-in-traditional-ceremony-as-graft-probe-haunts-family">Waititu weds wife in traditional ceremony as graft probe haunts family &#8211; PHOTOS</a></h3>
</div>
<div class="content-meta">
<span class="render-text">May 27th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/nairobi-man-fined-sh1-500-for-broad-daylight-sex-at-uhuru-park"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/BDNairobi1302z-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="BDNairobi1302z" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/BDNairobi1302z-470x264.jpg" title="BDNairobi1302z" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/nairobi-man-fined-sh1-500-for-broad-daylight-sex-at-uhuru-park">Nairobi man fined Sh1, 500 for broad daylight sex at Uhuru Park</a></h3>
</div>
<div class="content-meta">
<span class="render-text">May 29th, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/news/here-is-how-sonkos-new-luthuli-avenue-will-look-like-photos"><img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Luthuli3-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="Luthuli3" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/Luthuli3-470x264.jpg" title="Luthuli3" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/news/here-is-how-sonkos-new-luthuli-avenue-will-look-like-photos">Here is how Sonko’s new Luthuli Avenue will look like– PHOTOS</a></h3>
</div>
<div class="content-meta">
<span class="render-text">May 28th, 2019</span>
</div>
</div>
</div>
</div>
</div>
<div class="grid-4 cell">
<div class="pane-grid pane-container clearfix">
<div class="pane-title posRelative mb-20">
<div class="pane-title__content">
<div class="pane-title__heading">
<h2>
<a href="javascript:void(0);">Don't Miss</a>
</h2>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="DNBABUWINS0806f" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/08/DNBABUWINS0806f.jpg" title="DNBABUWINS0806f" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/featured/babu-owino-shares-his-softer-side-leaves-fans-swooning">Babu Owino shares his softer side, leaves fans swooning</a></h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/editors-picks/kq-explains-why-you-cant-change-seats-freely-in-half-empty-flights"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/10/WhatsApp-Image-2018-10-29-at-14.38.06-1saw-74x55.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="WhatsApp-Image-2018-10-29-at-14.38.06-(1)saw" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2018/10/WhatsApp-Image-2018-10-29-at-14.38.06-1saw.jpg" title="WhatsApp-Image-2018-10-29-at-14.38.06-(1)saw" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/editors-picks/kq-explains-why-you-cant-change-seats-freely-in-half-empty-flights">KQ explains why you can’t change seats freely in half-empty flights</a></h3>
</div>
 <div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</div>
<div class="pane-box">
<div class="pane-box__img">
<a href="https://nairobinews.nation.co.ke/editors-picks/sonko-redoes-the-nyayo-roundabout-despite-unaccounted-expenditure"> <img width="130" height="73" src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DvVfzJlXgAArFBc-150x150.jpg" class="attachment-footer-thumb size-footer-thumb wp-post-image" alt="DvVfzJlXgAArFBc" data-src="https://nairobinews.nation.co.ke/wp-content/uploads/2019/05/DvVfzJlXgAArFBc-470x264.jpg" title="DvVfzJlXgAArFBc" /></a>
</div>
<div class="pane-box__content">
<div class="content-title">
<h3><a href="https://nairobinews.nation.co.ke/editors-picks/sonko-redoes-the-nyayo-roundabout-despite-unaccounted-expenditure">Sonko redoes the Nyayo roundabout despite unaccounted expenditure</a></h3>
</div>
<div class="content-meta">
<span class="render-text">May 31st, 2019</span>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="bottom-footer text-center padt20 padb20">
<span class="render-text">
Copyright &copy; 2019 Nation Media Group. All rights reserved.
</span>
</div>
</footer>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.3.1/jquery.min.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/plugins.js"></script>
<script src="https://nairobinews.nation.co.ke/wp-content/themes/_nn_clean_v2/assets/js/app.js"></script>
<script>
    window.lazyLoadOptions = {	
        elements_selector: ".wp-post-image"
    };
</script>
<script async src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@11.0.6/dist/lazyload.min.js"></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
<script type="text/javascript">
    function updateURL(id) {
      if (history.pushState) {
          var newurl = window.location.protocol + "//" + window.location.host + window.location.pathname + '#'+id;
          window.history.pushState({path:newurl},'',newurl);
      }
    }
</script>
<script type='text/javascript' src='https://nairobinews.nation.co.ke/wp-includes/js/wp-embed.min.js'></script>


</body>
</html>